






<!DOCTYPE html>




<html lang="fi">
  <head prefix="og: http://ogp.me/ns# kalevamedia: https://www.kalevamedia.fi/ns#">
  
  <link rel="preconnect" href="https://crop.kaleva.fi">
  <link rel="preconnect" href="https://fonts.gstatic.com">
  <link rel="preconnect" href="https://googletagmanager.com">
  <link rel="preconnect" href="https://lyta.kalevamedia.fi">
  <link rel="preconnect" href="https://static.miilu.kalevakonserni.fi">
  <link rel="preconnect" href="https://sp.miilu.kalevakonserni.fi">
  <link rel="preconnect" href="https://ww2999.smartadserver.com">
  <link rel="preconnect" href="https://creatives.sascdn.com">
  <link rel="preload" href="https://ced.sascdn.com/tag/2999/smart.js" as="script">
  <link rel="preload" href="https://static.miilu.kalevakonserni.fi/consent/consent.js" as="script">
  
  <link rel="dns-prefetch" href="https://cdn.gravito.net">
  <link rel="dns-prefetch" href="https://cdn.jsdelivr.net">
  <link rel="preload" href="https://apps-cdn.relevant-digital.com/static/tags/61bc87a350fa1c66dc1b2c87.js" as="script">
  <link rel="preconnect" href="https://prg.smartadserver.com">
  <link rel="dns-prefetch" href="https://adx.adform.net">
  
    
      <script>
        window['gtag_enable_tcf_support'] = true;
        var stubScriptTag = document.createElement('script');
        stubScriptTag.innerHTML='"use strict";!function(){var e=function(){var e,t="__tcfapiLocator",a=[],n=window;for(;n;){try{if(n.frames[t]){e=n;break}}catch(e){}if(n===window.top)break;n=n.parent}e||(!function e(){var a=n.document,r=!!n.frames[t];if(!r)if(a.body){var s=a.createElement("iframe");s.style.cssText="display:none",s.name=t,a.body.appendChild(s)}else setTimeout(e,5);return!r}(),n.__tcfapi=function(){for(var e,t=arguments.length,n=new Array(t),r=0;r<t;r++)n[r]=arguments[r];if(!n.length)return a;if("setGdprApplies"===n[0])n.length>3&&2===parseInt(n[1],10)&&"boolean"==typeof n[3]&&(e=n[3],"function"==typeof n[2]&&n[2]("set",!0));else if("ping"===n[0]){var s={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof n[2]&&n[2](s)}else a.push(n)},n.addEventListener("message",(function(e){var t="string"==typeof e.data,a={};try{a=t?JSON.parse(e.data):e.data}catch(e){}var n=a.__tcfapiCall;n&&window.__tcfapi(n.command,n.version,(function(a,r){var s={__tcfapiReturn:{returnValue:a,success:r,callId:n.callId}};t&&(s=JSON.stringify(s)),e&&e.source&&e.source.postMessage&&e.source.postMessage(s,"*")}),n.parameter)}),!1))};"undefined"!=typeof module?module.exports=e:e()}();'
        document.head.appendChild(stubScriptTag)
      </script>
    
  

  <script src="/staticfiles/webpack_bundles/utils-adfbe0952b45b845fc7b.js" ></script>
  <script src="/staticfiles/webpack_bundles/vimeoUtils-adfbe0952b45b845fc7b.js" ></script>
    <script>
      digitalData = { 
        "channel": {
          "facebook_url": "https://www.facebook.com/KalevaOy",
          "domain": "www.kaleva.fi",
          "twitter_handle": "Kaleva_fi",
          "title": "Kaleva",
          "slug": "kalevafi",
        },
        "pageInstanceID": "4656010-prod",
        "page": {
          "category": {
            "pageType": "article",
            
          },
          "attributes": {
            "accessPolicy": "premium",
            "articleLength": 3757,
            "styleTree": "rich",
            "assetID": "4656010",
            "authors": ["Anne Lilja"],
            "contentSourceOrganization": "Kaleva",
            "contentSourceOrganizationExternalId": "",
            "contentSourceTitle": "Kaleva",
            "assetType": "journalistic",
            "genre": "Feature",
            "category": "Koti ja asuminen",
            "mainKeyword": "Asuminen",
            "keywords": ["Sisustus","Asuminen","Koti","Oulu","Koti ja asuminen",],
            "version": 1,
            "versionID": "4871063",
            
            "visibility": "normal",
            
            
            "isPreview": false, 
            "clientType": (function() {
              var client = "Browser";
              var ua = navigator.userAgent || navigator.vendor || window.opera;
              if(ua.indexOf("FBAN") > -1) {
                client = "Facebook_app";
              }
              return client;
            })(),
            "environment": "prod"
          },
          "pageInfo": {
            "author": "Anne Lilja",
            "pageID": "4656010",
            "issueDate": "2022-06-04T04:00:00Z",
            
            "language": "fi-FI",
            "geoRegion": "FI",
            "publisher": "Kaleva",
            "pageTitle": "Vintagea, hersyviä värejä ja kummallisia kalloja – oululaisnaisen sinkkukoti on rohkean viehättävä rauhan satama",
            "locationProtocol": document.location.protocol.slice(0, -1),
            "locationHost": "www.kaleva.fi",
            "locationPathName": "/vintagea-hersyvia-vareja-ja-kummallisia-kalloja-ou/4656010",
            "locationHref": "https://www.kaleva.fi/vintagea-hersyvia-vareja-ja-kummallisia-kalloja-ou/4656010",
          },
        },
        "user": [{
          "profile": {
            "profileID": utils.getMultipassId(),
            "snowplowID": utils.getSnowplowDuid()
          },
          "signInStatus": utils.getMultipassId() ? true : false,
          "subscriberStatus": utils.getSubscriberStatus('kalevafi'),
          "activeSubscriptions": utils.getActiveSubscriptions(),
          "isTrialAllowed": utils.getIsTrialAllowed()
        }]
      };

    </script>

    <script>
    var el = document.createElement('script');
    el.type = 'application/ld+json';
    el.text = JSON.stringify({
      "@context":"https://schema.org","@type":"Organization","url":"https://" + digitalData.channel.domain + "/","sameAs":[digitalData.channel.facebook_url],"@id":"https://" + digitalData.channel.domain + "/#organization","name":digitalData.channel.title,"logo":""});
    document.querySelector('head').appendChild(el);
  </script>

    <script>
    var el = document.createElement('script');
    el.type = 'application/ld+json';
    el.text = JSON.stringify({'@context': 'http://schema.org', '@type': 'NewsArticle', 'headline': 'Vintagea, hersyviä värejä ja kummallisia kalloja\u2009–\u2009oululaisnaisen sinkkukoti on rohkean viehättävä rauhan satama', 'slug': 'vintagea-hersyvia-vareja-ja-kummallisia-kalloja-ou', 'description': 'Kerrostalokaksio on sisustettu menneiden vuosikymmenten kalusteilla ja hersyvillä väreillä.', 'datePublished': '2022-06-04T04:00:00+00:00', 'publisher': {'name': 'Kaleva', '@type': 'Organization', 'url': 'https://kaleva.fi'}, 'isAccessibleForFree': 'False'});
    document.querySelector('head').appendChild(el);
  </script>

    
    <script>
        (function() {
            function nestedAttributeExists(obj, path) {
                var pathParts = path.split('.');

                for (var i = 0; i < pathParts.length; i++) {
                    if (!obj || !obj.hasOwnProperty(pathParts[i])) {
                        return { status: false };
                    }
                    obj = obj[pathParts[i]];
                }
                return { status: true, value: obj };
            }

            var initialDataLayerObject = (function() {
                var initialData = {};
                var dateFormatter = function(date) {
                    var d = new Date(date);
                    d.setMilliseconds(0);
                    return d.toISOString().replace('.000', '');
                }
                var initialize = function(path, targetKey, defaultValue, formatter) {
                    var pathParts = path.split('.');
                    var target = pathParts[pathParts.length -1];
                    if (targetKey) {
                        target = targetKey;
                    }
                    var result = nestedAttributeExists(digitalData, path);
                    if (result.status) {
                        initialData[target] = result.value;
                    } else {
                        if (defaultValue !== undefined) {
                            initialData[target] = defaultValue;
                        }
                    }
                    if (initialData.hasOwnProperty(target) && formatter) {
                        initialData[target] = formatter(initialData[target]);
                    }
                }
                initialize('page.attributes.accessPolicy', 'accessPolicy');
                initialize('page.attributes.articleLength');
                initialize('page.attributes.styleTree');
                initialize('page.attributes.assetType', undefined, undefined, function(assetType) {
                    return assetType === 'user-generated' ? 'user' : assetType;
                });
                initialize('page.attributes.assetID');
                initialize('page.attributes.clientType');
                initialize('page.attributes.environment');
                initialize('page.category.pageType');
                initialize('page.pageInfo.author', 'authorString');
                initialize('page.attributes.authors', 'author');
                initialize('page.pageInfo.issueDate', 'publicationDate', undefined, dateFormatter);
                initialize('page.pageInfo.effectiveDate', 'modificationDate', undefined, dateFormatter);
                initialize('page.attributes.contentSourceOrganization', 'sourceOrganization');
                initialize('page.attributes.contentSourceTitle', 'sourceTitle');
                initialize('page.attributes.contentSourceOrganizationExternalId', 'sourceOrganizationExternalID');
                initialize('page.category.primaryCategory');
                initialize('page.attributes.category');
                initialize('page.attributes.genre');
                initialize('page.attributes.mainKeyword');
                initialize('page.attributes.keywords');
                if (initialData.hasOwnProperty('keywords')) {
                    initialData['keywordsString'] = initialData.keywords.join(',');
                }
                initialize('page.pageInfo.pageTitle');
                initialize('page.attributes.videoDuration');
                initialize('page.pageInfo.pageID');
                initialize('page.pageInfo.locationHref');
                initialize('channel.domain', 'channelDomain');
                initialize('channel.slug', 'channelSlug');
                initialize('page.attributes.version', 'assetVersion');
                initialize('page.attributes.versionID', 'assetVersionID');
                initialize('user.0.signInStatus', 'signInStatus');
                initialize('user.0.subscriberStatus', 'subscriberStatus');
                initialize('user.0.activeSubscriptions', 'activeSubscriptions');
                initialize('user.0.isTrialAllowed', 'isTrialAllowed');
                initialize('user.0.profile.profileID', 'userID');
                initialize('product.0.productInfo.productName');
                initialize('page.pageInfo.publisher');
                initialize('page.attributes.itemCount');
                initialize('page.attributes.itemIndex');
                initialize('page.attributes.isPreview');
                initialize('page.attributes.visibility');
                return initialData;
            })();

            window.dataLayer = [initialDataLayerObject];
        })();
    </script>


    
    <script>
      /*
        Dispatch for any events that need to be reflected in analytics.
      */
      var LorienDispatch = (function () {
        var handlers = [];
        return {
          registerEventHandler: function (handler, eventsOfInterest) {
            handlers.push({handler: handler, eventsOfInterest: eventsOfInterest});
          },
          dispatchEvent: function (event, value) {
            var i = 0;
            for (i = 0; i < handlers.length; i++) {
              if (handlers[i].eventsOfInterest.indexOf(event) > -1) {
                handlers[i].handler(event, value);
              }
            }
          }
        };
      })();

      // Event handlers
      LorienDispatch.registerEventHandler(
        function (event, value) {
          var message = false;
          if (event === 'userLogin') {
            message = {'signInStatus': value.signInStatus, 'subscriberStatus': value.subscriberStatus};
          } else {
            message = value;
            message.event = event;
          }
          if (message) {
            dataLayer.push(message);
          }
        },
        [
          "userLogin", "managedListingClick", "managedListingDisplay", "socialMediaShare",
          "virtualPageView", "managedListingItemImpression", "articleReadingPosition",
          "snowplow", "personalizedSnackbarRecommendationImpression", "audioEvent", "managedListingDismissed",
          "loginWallEvent",
        ]
      );

      LorienDispatch.registerEventHandler(function (event, value) {
          if (event === 'userLogin') {
            digitalData.user[0].signInStatus = value.signInStatus;
            digitalData.user[0].subscriberStatus = value.subscriberStatus;
          }
        },
        ["userLogin"]
      );

    </script>


    
  <script type="text/javascript">
    var SnowPlowDispatch = (function() {
      return {
        offerClaimEvent: function() {
          LorienDispatch.dispatchEvent('snowplow', {
            structuredEvent: {
              eventCategory: 'Offer Tracking',
              eventAction: 'Offer Claimed',
            },
            _clear: true,
          });
        },
        offerViewEvent: function() {
          LorienDispatch.dispatchEvent('snowplow', {
            structuredEvent: {
              eventCategory: 'Offer Tracking',
              eventAction: 'Offer Viewed',
            },
            _clear: true,
          });
        }
      };
  })()
  </script>


    
      
  
    <!-- Google Tag Manager -->
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl+ '';f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-P26833H');</script>
    <!-- End Google Tag Manager -->
  

    

    <meta charset="utf-8">
    <meta http-equiv="x-ua-compatible" content="ie=edge"><script type="text/javascript">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</script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","errorBeacon":"bam-cell.nr-data.net","licenseKey":"99670b3c8a","applicationID":"244321654","transactionName":"ZFBRMUoDCkFVBUxeX10adRBWARBbWwgXW19dUVxLSwsQVxoQUVJHQA9yFksHEGRdA08ZV1ZB","queueTime":25,"applicationTime":366,"agent":""}</script>
    <title>Vintagea, hersyviä värejä ja kummallisia kalloja – oululaisnaisen sinkkukoti on rohkean viehättävä rauhan satama | Kaleva</title>
    
    <meta name="viewport" content="width=device-width, initial-scale=1.0">

    <script src="https://cdnjs.cloudflare.com/ajax/libs/loadjs/3.5.4/loadjs.min.js"></script>
    <meta name="twitter:card" content="summary_large_image"/>
    <meta name="twitter:site" content="@Kaleva_fi" />
  <meta name="description" content="Kerrostalokaksio on sisustettu menneiden vuosikymmenten kalusteilla ja hersyvillä väreillä.">
    
    <meta property="og:title" content="Vintagea, hersyviä värejä ja kummallisia kalloja – oululaisnaisen sinkkukoti on rohkean viehättävä rauhan satama">
    <meta property="og:description" content="Kerrostalokaksio on sisustettu menneiden vuosikymmenten kalusteilla ja hersyvillä väreillä.">
    <meta property="og:url" content="https://www.kaleva.fi/vintagea-hersyvia-vareja-ja-kummallisia-kalloja-ou/4656010">
    <meta property="og:image" content="https://crop.kaleva.fi/A2psMcyfFPDOeG424Ym5wGQyPyc=/1200x630/smart/filters:watermark(https://lorien-media-prod.s3.amazonaws.com/images/archive/2020/05/07/2020.05.07.09.07.30_watermark_kalevafi_stripe.png,repeat,-0,0):watermark(https://lorien-media-prod.s3.amazonaws.com/images/archive/2020/05/07/2020.05.07.09.06.40_watermark_kalevafi_logo.png,50,0,0)/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/05/19/2022.05.19.14.19.31_neo-6906564.jpg">
  
    <meta property="og:image:width" content="1200">
    <meta property="og:image:height" content="630">
    <meta property="og:type" content="article">
    <meta property="og:site_name" content="Kaleva">
    <meta property="fb:app_id" content="499246010097508" />
    <link rel="canonical" href="https://www.kaleva.fi/vintagea-hersyvia-vareja-ja-kummallisia-kalloja-ou/4656010" />
    <meta property="og:locale" content="fi_FI">
    
  
    
    
      <meta property="kalevamedia:image" content="https://crop.kaleva.fi/SWjddJVj60Uj61ZTDKpaRkLjwzs=/1290x860/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/05/19/2022.05.19.14.19.31_neo-6906564.jpg">
    
  

    
    <!--[if lt IE 9]>
      <script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
    <![endif]-->
    <script src="https://cdn.polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"></script>
    <script>window._APP_GLOBALS = {"DELIVERY_API_BASE_URL": "https://api.kalevamedia.fi", "X_API_KEY": "HSyHVnWuN96Lvm65vjoln7cFICoF4hDj65SEgsiz", "FACEBOOK_CLIENT_TOKEN": "499246010097508|db3423138889adf9535ac808b328f6a1"};</script>
    <link rel="icon" href="/staticfiles/londo/images/favicons/kalevafi.74cd970a48ae.ico">
    <link rel="stylesheet" href="https://fonts.googleapis.com/icon?family=Material+Icons">

    
      
      <link href="/staticfiles/londo/styles/main_kalevafi.543fa8498002.css" rel="stylesheet">
    

    
    
      
      
  
  <script>
    var LytaConfig = {
      site: "sites-lorien",
      debug: false,
      interstitialCookieExpiry: 60*15,
      queueAds: true,
      lazyLoadAds: true,
      uidCookieName: '__aduid',
      smart: {
        networkId: 2999,
        host: 'ww2999.smartadserver.com',
        forceSSL: false,
        siteId: 213338,
        pageId: 1142450
      },
      target: {
        adCategory: '',
        pageType : '',
        keywords: []
      }
    };
    LytaConfig.relevant = {
      enabled: true,
      scriptUrl: "https://apps-cdn.relevant-digital.com/static/tags/61bc87a350fa1c66dc1b2c87.js",
      configId: "62026411d14376cd94dbb1ca",
      stdCall: true,
    };

    if (typeof digitalData.page.attributes.keywords === 'object' && digitalData.page.attributes.keywords.length > 0) {
      LytaConfig.target.keywords = digitalData.page.attributes.keywords;
    }

    if (typeof digitalData.page.attributes.assetID === 'string') {
      LytaConfig.target.assetId = digitalData.page.attributes.assetID;
    }

    if (typeof digitalData.page.category.primaryCategory === 'string') {
      LytaConfig.target.adCategory = digitalData.page.category.primaryCategory;
    }

    if (typeof digitalData.page.attributes.clientType === 'string') {
      LytaConfig.target.clientType = digitalData.page.attributes.clientType;
    }

    if (typeof digitalData.user === 'object' && digitalData.user.length === 1) {
      LytaConfig.target.user = digitalData.user[0];
    }

    if (typeof digitalData.page.category.pageType === 'string') {
      switch (digitalData.page.category.pageType) {
        case 'Front page':
          LytaConfig.target.pageType = 'etusivu';
          break;
        case 'article':
          LytaConfig.target.pageType = 'artikkeli';
          break;
        case 'AggregationPage':
        case 'Cartoon list':
          LytaConfig.target.pageType = 'listaus';
          break;
        
        case 'video':
          LytaConfig.target.pageType = 'videot';
          break;
        default:
          LytaConfig.target.pageType = digitalData.page.category.pageType;
      }
    }
  </script>

  <script src="https://lyta.kalevamedia.fi/1.8.1/lyta.js"></script>
  

    

    
  
  
  
    
  
  
  <!-- Strossle SDK --><script>window.strossle=window.strossle||function(){(strossle.q=strossle.q||[]).push(arguments)};strossle('00bf6fb7-ba92-4c35-ad3d-630e6e9ff21f', '.strossle-widget');</script><script async src="https://assets.strossle.com/strossle-widget-sdk/1/strossle-widget-sdk.js"></script><!-- End Strossle SDK -->
  

  

  </head>
  <body class="withMainHeaderToggle mainHeaderHidden ">
    
    
      
  
    <!-- Google Tag Manager (noscript) -->
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P26833H"
    height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->
  

    
    
    
    <div class="drawer-menu-guardian">
      <aside class="mdc-drawer mdc-drawer--modal">
        <div class="mdc-drawer__content">
          <nav class="drawer__list">
            




  



  <div class="drawer__wrapper">
    <ul class="drawer-menu drawer-menu--level-1 js-drawer-menu">
      
  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--uutiset-2 -title">
    

      
        
      

      

      
        <span class="drawer-menu__item-title drawer-menu__item-title--level-1 drawer-menu__item-title--uutiset-2">
          Uutiset
        </span>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--etusivu-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--etusivu-2" >
          Etusivu
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--oulun-seutu-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/oulun-seutu" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--oulun-seutu-2" >
          Oulun seutu
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--pohjois-suomi-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/pohjois-suomi" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--pohjois-suomi-2" >
          Pohjois-Suomi
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--forum24-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/forum24" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--forum24-2" >
          Forum24
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kotimaa-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/kotimaa" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kotimaa-2" >
          Kotimaa
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--urheilu-3 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/urheilu" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--urheilu-3" >
          Urheilu
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kiekko-kaleva -normal">
    

      
        
      

      

      
        
          
        
        <a href="/kiekko-kaleva" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kiekko-kaleva" >
          Kiekko-Kaleva
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kaleva-live -normal">
    

      
        
      

      

      
        
          
        
        <a href="/live" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kaleva-live" >
          Kaleva Live
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--ulkomaat-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/ulkomaat" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--ulkomaat-2" >
          Ulkomaat
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kulttuuri-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/kulttuuri" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kulttuuri-2" >
          Kulttuuri
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--historia -normal">
    

      
        
      

      

      
        
          
        
        <a href="/historia" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--historia" >
          Historia
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--luonto-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/luonto" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--luonto-2" >
          Luonto
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--hyva-elama-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/hyva-elama" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--hyva-elama-2" >
          Hyvä elämä
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--ruoka -normal">
    

      
        
      

      

      
        
          
        
        <a href="/ruoka" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--ruoka" >
          Ruoka
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--koti-kaleva -normal">
    

      
        
      

      

      
        
          
        
        <a href="/koti" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--koti-kaleva" >
          Koti-Kaleva
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--oikaisut -normal">
    

      
        
      

      

      
        
          
        
        <a href="/oikaisut" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--oikaisut" >
          Oikaisut
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--haku -normal">
    

      
        
      

      

      
        
          
        
        <a href="/haku" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--haku" >
          Haku
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item---5 -separator">
    
      <div class="drawer-menu__item-separator drawer-menu__item-separator--level-1"></div>
    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--uusimmat -normal">
    

      
        
      

      

      
        
          
        
        <a href="/uutiset" class="drawer-menu__item-link drawer-menu__item-link--level-1 drawer-menu__item-link--uusimmat" >
          Uusimmat
        </a>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--galleriat-7 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/galleriat/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--galleriat-7" >
          Galleriat
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--videot-4 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/videot/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--videot-4" >
          Videot
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--lukijakuvat-ja-videot -normal">
    

      
        
      

      

      
        
          
        
        <a href="/lukijalta" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--lukijakuvat-ja-videot" >
          Lukijakuvat ja -videot
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--laheta-kuva-tai-video-3 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/lukijalta/laheta" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--laheta-kuva-tai-video-3" >
          Lähetä kuva tai video
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--podcastit-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/podcastit" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--podcastit-2" >
          Podcastit
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--sarjakuvat -normal">
    

      
        
      

      

      
        
          
        
        <a href="/sarjakuvat/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--sarjakuvat" >
          Sarjakuvat
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--ristikot-ja-sudokut-7 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/ajanviete" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--ristikot-ja-sudokut-7" >
          Ristikot ja Sudokut
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--saa-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/saa" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--saa-2" >
          Sää
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--tapahtumat-3 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/tapahtumat" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--tapahtumat-3" >
          Tapahtumat
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--ura -normal">
    

      
        
      

      

      
        
          
        
        <a href="/ura" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--ura" >
          Ura
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item---6 -separator">
    
      <div class="drawer-menu__item-separator drawer-menu__item-separator--level-1"></div>
    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--radio-kaleva -highlight">
    

      
        
      

      <div class="drawer-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://www.radiokaleva.fi/" class="drawer-menu__item-link drawer-menu__item-link--level-1 drawer-menu__item-link--radio-kaleva" >
          Radio Kaleva
        </a>
      

      </div>

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item---7 -separator">
    
      <div class="drawer-menu__item-separator drawer-menu__item-separator--level-1"></div>
    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--mielipiteet-2 -title">
    

      
        
      

      

      
        
          
        
        <a href="/mielipiteet" class="drawer-menu__item-title drawer-menu__item-title--level-1 drawer-menu__item-title--mielipiteet-2" >
          Mielipiteet
        </a>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--paakirjoitukset-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/paakirjoitukset" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--paakirjoitukset-2" >
          Pääkirjoitukset
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kolumnit-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/kolumnit" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kolumnit-2" >
          Kolumnit
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--lukijan-mielipide -normal">
    

      
        
      

      

      
        
          
        
        <a href="/mielipiteet" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--lukijan-mielipide" >
          Lukijan mielipide
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item---11 -separator">
    
      <div class="drawer-menu__item-separator drawer-menu__item-separator--level-1"></div>
    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--nakoislehdet-3 -title">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/" class="drawer-menu__item-title drawer-menu__item-title--level-1 drawer-menu__item-title--nakoislehdet-3" >
          Näköislehdet
        </a>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kaleva -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/kaleva/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kaleva" >
          Kaleva
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--rantalakeus -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/rantalakeus/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--rantalakeus" >
          Rantalakeus
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--siikajokilaakso -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/siikajokilaakso/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--siikajokilaakso" >
          Siikajokilaakso
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--iijokiseutu -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/iijokiseutu/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--iijokiseutu" >
          Iijokiseutu
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--pyhajokiseutu -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/pyhajokiseutu/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--pyhajokiseutu" >
          Pyhäjokiseutu
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item---14 -separator">
    
      <div class="drawer-menu__item-separator drawer-menu__item-separator--level-1"></div>
    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--kaupallinen-yhteistyo-4 -title">
    

      
        
      

      

      
        
          
        
        <a href="/kaupallinen-yhteistyo" class="drawer-menu__item-title drawer-menu__item-title--level-1 drawer-menu__item-title--kaupallinen-yhteistyo-4" >
          Kaupallinen yhteistyö
        </a>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--pohjois-pohjanmaan-yrittajat -normal">
    

      
        
      

      

      
        
          
        
        <a href="/ppy" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--pohjois-pohjanmaan-yrittajat" >
          Pohjois-Pohjanmaan yrittäjät
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--asianajo-ja-lakiasiaintoimistot -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://sivustot.kaleva.fi/asianajajat/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--asianajo-ja-lakiasiaintoimistot" target="_blank" rel="noopener">
          Asianajo- ja lakiasiaintoimistot
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--ruka-landingbag -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://sivustot.kaleva.fi/rukalandingbag/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--ruka-landingbag" target="_blank" rel="noopener">
          Ruka Landingbag
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kasvun-paikka-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://sivustot.kaleva.fi/kasvunpaikka/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kasvun-paikka-2" target="_blank" rel="noopener">
          Kasvun paikka
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--geopark-challenge-2021 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.kaleva.fi/geoparkchallenge" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--geopark-challenge-2021" >
          Geopark Challenge 2021
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--laheta-uutisvinkki-2 -highlight">
    

      
        
      

      <div class="drawer-menu__item--highlight-wrapper">

      
        
          
        
        <a href="/lukijalta/laheta" class="drawer-menu__item-link drawer-menu__item-link--level-1 drawer-menu__item-link--laheta-uutisvinkki-2" target="_blank" rel="noopener">
          Lähetä uutisvinkki
        </a>
      

      </div>

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--tilaa-kaleva-3 -highlight">
    

      
        
      

      <div class="drawer-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/tilaa-kaleva-3/?utm_source=sivusto&amp;utm_medium=kaleva&amp;utm_campaign=valikko" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--tilaa-kaleva-3" target="_blank" rel="noopener">
          Tilaa Kaleva
        </a>
      

      </div>

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--asiakaspalvelu-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/" class="drawer-menu__item-link drawer-menu__item-link--level-1 drawer-menu__item-link--asiakaspalvelu-2" target="_blank" rel="noopener">
          Asiakaspalvelu
        </a>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--hallitse-tilauksiasi -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://itsepalvelu.kalevamedia.fi" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--hallitse-tilauksiasi" target="_blank" rel="noopener">
          Hallitse tilauksiasi
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kumppaniedut -normal">
    

      
        
      

      

      
        
          
        
        <a href="/kumppaniedut" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kumppaniedut" >
          Kumppaniedut
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--yhteystiedot-6 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/yhteystiedot/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--yhteystiedot-6" target="_blank" rel="noopener">
          Yhteystiedot
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--palvelumme-yrityksille-5 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.kalevamedia.fi/yrityksille" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--palvelumme-yrityksille-5" target="_blank" rel="noopener">
          Palvelumme yrityksille
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--palaute-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/yhteystiedot/ota-yhteytta/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--palaute-2" target="_blank" rel="noopener">
          Palaute
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

    </ul>
  </div>

          </nav>
        </div>
      </aside>
      <div class="mdc-drawer-scrim"></div>
    </div>
    
    

    
    
  
  <div class="collapsingHeader">
    <div class="collapsingHeader__collapseItems">
      
  <nav id="main-nav">
    <div class="main-nav__row">
      <section class="main-nav__row__section main-nav__row__section--align-start">
        
             <button class="material-icons menu top-bar-menu__navigation-icon top-bar-menu__navigation-icon--menu" >menu</button>
        
        <nav>
          




  



  <div class="top-bar__wrapper">
    <ul class="top-bar-menu top-bar-menu--level-1 js-top-bar-menu">
      
  <li class="top-bar-menu__item top-bar-menu__item--level-1 top-bar-menu__item--asiakaspalvelu-16 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/" class="top-bar-menu__item-link top-bar-menu__item-link--level-1 top-bar-menu__item-link--asiakaspalvelu-16" target="_blank" rel="noopener">
          Asiakaspalvelu
        </a>
      

      

    

    
  </li>

  <li class="top-bar-menu__item top-bar-menu__item--level-1 top-bar-menu__item--tilaa-kaleva -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/tilaa-kaleva-3/?utm_source=kaleva&amp;utm_medium=navi&amp;utm_campaign=topbar" class="top-bar-menu__item-link top-bar-menu__item-link--level-1 top-bar-menu__item-link--tilaa-kaleva" target="_blank" rel="noopener">
          Tilaa Kaleva
        </a>
      

      

    

    
  </li>

  <li class="top-bar-menu__item top-bar-menu__item--level-1 top-bar-menu__item--palvelumme-yrityksille-4 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.kalevamedia.fi/yrityksille" class="top-bar-menu__item-link top-bar-menu__item-link--level-1 top-bar-menu__item-link--palvelumme-yrityksille-4" target="_blank" rel="noopener">
          Palvelumme yrityksille
        </a>
      

      

    

    
  </li>

  <li class="top-bar-menu__item top-bar-menu__item--level-1 top-bar-menu__item--haku-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/haku" class="top-bar-menu__item-link top-bar-menu__item-link--level-1 top-bar-menu__item-link--haku-2" >
          Haku
        </a>
      

      

    

    
  </li>

    </ul>
  </div>

          
        </nav>
      </section>
      <section class="main-nav__row__section main-nav__row__section--align-end">
        
  <a class="top-bar-menu__item-link top-bar-menu__item-link--level-1 js-user-login-link"
    href="/leeloo/kirjaudu/?brand=kalevafi">
      <span class="material-icons top-bar-menu__navigation-icon">account_circle</span>
      <span class="top-bar-menu__item-link--navigation-text">Kirjaudu</span>
  </a>

      </section>
    </div>
  </nav>


      
  
  
  
  
  
  <header id="main-header">
    <div id="main-header__row">
      <section class="main-header__section main-header__section--left">
        <div class="main-header__section--left-logo">
          <a href="/" class="main-header__logo--link">
            <img src="/staticfiles/londo/domains/kalevafi/site/images/kalevafi--logo-2x.31853ca9aef6.png" alt="Kaleva" />
          </a>
        </div>
        <div class="main-header__section--left-links">
          




  



  <div class="header__wrapper">
    <ul class="header-menu header-menu--level-1 js-header-menu">
      
  <li class="header-menu__item header-menu__item--level-1 header-menu__item--oulun-seutu -normal">
    

      
        
      

      

      
        
          
        
        <a href="/oulun-seutu" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--oulun-seutu" >
          Oulun seutu
        </a>
      

      

    

    
  </li>

  <li class="header-menu__item header-menu__item--level-1 header-menu__item--pohjois-suomi -normal">
    

      
        
      

      

      
        
          
        
        <a href="/pohjois-suomi" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--pohjois-suomi" >
          Pohjois-Suomi
        </a>
      

      

    

    
  </li>

  <li class="header-menu__item header-menu__item--level-1 header-menu__item--uusimmat-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/uutiset" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--uusimmat-2" >
          Uusimmat
        </a>
      

      

    

    
  </li>

  <li class="header-menu__item header-menu__item--level-1 header-menu__item--radio-kaleva-4 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.radiokaleva.fi/" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--radio-kaleva-4" target="_blank" rel="noopener">
          Radio Kaleva
        </a>
      

      

    

    
  </li>

  <li class="header-menu__item header-menu__item--level-1 header-menu__item--lukijalta-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/lukijalta" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--lukijalta-2" >
          Lukijalta
        </a>
      

      

    

    
  </li>

  <li class="header-menu__item header-menu__item--level-1 header-menu__item--nakoislehdet-4 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/kaleva" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--nakoislehdet-4" >
          Näköislehdet
        </a>
      

      

    

    
  </li>

    </ul>
  </div>

        </div>
      </section>
      
        <section class="main-header__section main-header__section--right">
          


  
  
    <div class="weather-widget weather-widget--header">
      <iframe src="https://vanha.kaleva.fi/saa/ext/widget/oulu/" frameborder="0" scrolling="no" style="max-height: 100%; min-width: 100%; width: 100%"></iframe>
    </div>
  

        </section>
      
    </div>
  </header>

    </div>
    <div class="mainHeaderOpenButtonContainer -toggle-theme-dark">
      <button class="mainHeaderOpenButton -toggle-theme-dark" onClick=window.toggleMainHeader()></button>
      <a href="/" class="mainHeaderOpenLink -toggle-theme-dark">
        <img src="/staticfiles/londo/domains/kalevafi/site/images/kalevafi--white-logo-1x.4e0d035230d6.png"
             class="mainHeaderOpenLogo -toggle-theme-dark"
        />
      </a>
    </div>
  </div>


    

    

    

    

    
  
  
  
    
  

  <article class="article -rich -with-hero -with-paywall-dark">
  
  
  
  
    
  <div class="article__hero -image">
    
      
  

   

  
   

  

    
  
  
  
  

  
  

  
  
  
    
    
    
  
  
  
    

    
        
    

    
    
      
      
        
      
    
      
      
        
      
    
      
      
        
      
    
      
      
        
      
    
      
      
        
      
    
    
    
    
    
    <div class="responsive-image-wrapper  article__heroImage-wrap" style="">
      
      
        <img class="responsive-image-placeholder article__heroImage-placeholder"
             style="min-width: 150.0vh; height: 66.667vw;"
             src="https://crop.kaleva.fi/RvDv8hVTJBxXxkL1uF_k8aOfXR4=/100x67/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/05/19/2022.05.19.14.20.24_neo-6906578.jpg" />
      
      <img class="responsive-image article__heroImage-image lozad"
           data-srcset="https://crop.kaleva.fi/RvDv8hVTJBxXxkL1uF_k8aOfXR4=/100x67/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/05/19/2022.05.19.14.20.24_neo-6906578.jpg 100w, https://crop.kaleva.fi/MVV-CLWiX9hQkklLrEHceK6JtEU=/400x267/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/05/19/2022.05.19.14.20.24_neo-6906578.jpg 400w, https://crop.kaleva.fi/BgEFIVXzTSUZDBi2hmbbn6yudZk=/800x533/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/05/19/2022.05.19.14.20.24_neo-6906578.jpg 800w, https://crop.kaleva.fi/jD0dieGu0FDZM_OcwYGcZkFqysg=/1400x933/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/05/19/2022.05.19.14.20.24_neo-6906578.jpg 1400w, https://crop.kaleva.fi/8y78pSV1pkly2py3inK5A0DCFac=/2600x1733/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/05/19/2022.05.19.14.20.24_neo-6906578.jpg 2600w"
           style="min-width: 150.0vh; height: 66.667vw;"
           sizes="(max-width:100px) 100px, (max-width:400px) 400px, (max-width:800px) 800px, (max-width:1400px) 1400px, 2600px"
           data-src="https://crop.kaleva.fi/8y78pSV1pkly2py3inK5A0DCFac=/2600x1733/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/05/19/2022.05.19.14.20.24_neo-6906578.jpg"
           
           alt="-"
         />
    </div>
  

    
    
  
  <header class="mdc-layout-grid article__header -rich -on-hero">
    <div class="mdc-layout-grid__inner">
      <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-12-desktop mdc-layout-grid__cell--span-12-tablet mdc-layout-grid__cell--span-2-mobile">
        <div class="article__badge-container">
  
</div>
        <h1 class="article__rich-headline -on-hero">Vin­ta­ges­ta vie­hät­ty­nyt</h1>
        <h2 class="article__rich-lead hidden-phone-down -on-hero">Kerrostalokaksio on sisustettu menneiden vuosikymmenten kalusteilla ja hersyvillä väreillä.</h2>
      </div>
    </div>
  </header>

  </div>
  
  <div class="mdc-layout-grid hidden-tablet-up article__rich-lead-after-hero-container">
    
      <div class="mdc-layout-grid__inner">
        <div class="mdc-layout-grid__cell">
          <h2 class="article__rich-lead -after-hero">Kerrostalokaksio on sisustettu menneiden vuosikymmenten kalusteilla ja hersyvillä väreillä.</h2>
        </div>
      </div>
    
  </div>

  
  

  
  
  
    
  
  <main class="article__body -rich -with-paywall-dark">
    
    
      <div class="article__richDarkPaywallWrapper">
        <div class="mdc-layout-grid">
          <div class="mdc-layout-grid__inner">
            <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-2-desktop mdc-layout-grid__cell--span-1-tablet hidden-phone-down"></div>
            <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-8-desktop mdc-layout-grid__cell--span-10-tablet">
              
  

  
    
    <script src="https://mpcdn.kaleva.fi/paywall/paywall-stub.js" type='text/javascript'></script>
    <script src="https://mpcdn.kaleva.fi/staticfiles/paywall/js/iframeResizer.min.js" type='text/javascript'></script>
    <div id="paywall-container" class="-theme-dark"></div>
    <script>
      (function() {
        let channelSlug = 'kalevafi';
        const forcePaywallSlug = null;
        if (channelSlug.endsWith('fi')) {
          channelSlug = channelSlug.substring(0, channelSlug.length - 2);
        }
        let paywallSlug = forcePaywallSlug;
        if (!paywallSlug) {
          paywallSlug = channelSlug + '-tahtijuttu';

          if (utils.getIsTrialAllowed() === false) {
            paywallSlug += '-paid';
          } else {
            paywallSlug += '-trial';
          }
        }
        window.KalevaPaywall.init({
            element: '#paywall-container',
            paywallSlug: paywallSlug,
            paywallHost: 'https://mpcdn.kaleva.fi',
            'theme': 'dark',
            contentUrl: window.location.href,
            multipassID: utils.getMultipassId()
        });
      })();
    </script>
  

            </div>
          </div>
        </div>
      </div>
    
  </main>

  

  </article>

  <div class="mdc-layout-grid">
    
      
  
  <section class="mdc-layout-grid__inner">
    <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-12-desktop mdc-layout-grid__cell--span-12-tablet">
      <div class="strossle-container">
        <div class="strossle-widget"></div>
      </div>
    </div>
  </section>

  <div class="article-middle">
    <div class="article-middle__separator"></div>
  </div>
  

    

    <section class="mdc-layout-grid__inner">
      <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-2-desktop mdc-layout-grid__cell--span-1-tablet hidden-phone-down"></div>
      <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-8-desktop mdc-layout-grid__cell--span-10-tablet discussion-container">
        
          
  
  
  
  <div id="kommentit">
    
      
<div class="__widget_Discussion" data-uninitialized="true"></div>

<script>
  (function() {
  var initKey = 'data-uninitialized';
  var el = document.querySelector('.__widget_Discussion[' + initKey + '=true]');
  el.removeAttribute(initKey);
  var scripts = ["/staticfiles/webpack_bundles/app-adfbe0952b45b845fc7b.js"];
  var loadComponent = function() {
    Loadable.preloadReady().then(function() {
      var renderMethod = el.childElementCount ? 'hydrate': 'render';
      ReactDOM[renderMethod](
        React.createElement(
          Provider,
          { store: createLocalStore({}) },
           React.createElement(Components.Discussion,
             
               {"discussionApiHost": "https://api.kalevamedia.fi", "appSlug": "kalevafi", "threadSlug": "article-4656010", "xApiKey": "HSyHVnWuN96Lvm65vjoln7cFICoF4hDj65SEgsiz", "loginUrl": "/leeloo/kirjaudu/?brand=kalevafi", "signupUrl": "/leeloo/kirjaudu/?luotunnus=1&brand=kalevafi"}
             
           )
         ),
         el
        );
    });
  };
  var require = function (scripts, callbackFn) {
    scripts.forEach(function(script) {
      if (!loadjs.isDefined(script)) {
        loadjs(script, script);
      }
    });
    loadjs.ready(scripts, callbackFn);
  };
  require(scripts, loadComponent);
 })();
</script>

    
  </div>

        
      </div>
    </section>

    <section class="mdc-layout-grid__inner">
      <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-2-desktop mdc-layout-grid__cell--span-1-tablet hidden-phone-down"></div>
      <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-8-desktop mdc-layout-grid__cell--span-10-tablet">
        <div class="content-widget--frontpage-now -ctx-article">
          
          
          
<div class="__widget_TabbedContentWidget" data-uninitialized="true"></div>

<script>
  (function() {
  var initKey = 'data-uninitialized';
  var el = document.querySelector('.__widget_TabbedContentWidget[' + initKey + '=true]');
  el.removeAttribute(initKey);
  var scripts = ["/staticfiles/webpack_bundles/app-adfbe0952b45b845fc7b.js"];
  var loadComponent = function() {
    Loadable.preloadReady().then(function() {
      var renderMethod = el.childElementCount ? 'hydrate': 'render';
      ReactDOM[renderMethod](
        React.createElement(
          Provider,
          { store: createLocalStore({}) },
           React.createElement(Components.TabbedContentWidget,
             
               {"title": "Etusivulla nyt", "styleContext": "-ctx-frontpage-now -level-1", "imageFormat": "ratio_3x2", "imageSize": 410, "tabs": [{"title": "Uusimmat", "query": "/api/v2/channels/kalevafi/managed-listings/etusivu/?limit=30&omit=content.gallery.items"}], "ugcRibbonVersion": "small"}
             
           )
         ),
         el
        );
    });
  };
  var require = function (scripts, callbackFn) {
    scripts.forEach(function(script) {
      if (!loadjs.isDefined(script)) {
        loadjs(script, script);
      }
    });
    loadjs.ready(scripts, callbackFn);
  };
  require(scripts, loadComponent);
 })();
</script>

        </div>
      </div>
    </section>

    
    
      
      
<div class="__widget_MobileMenuSnackbar" data-uninitialized="true"></div>

<script>
  (function() {
  var initKey = 'data-uninitialized';
  var el = document.querySelector('.__widget_MobileMenuSnackbar[' + initKey + '=true]');
  el.removeAttribute(initKey);
  var scripts = ["/staticfiles/webpack_bundles/app-adfbe0952b45b845fc7b.js"];
  var loadComponent = function() {
    Loadable.preloadReady().then(function() {
      var renderMethod = el.childElementCount ? 'hydrate': 'render';
      ReactDOM[renderMethod](
        React.createElement(
          Provider,
          { store: createLocalStore({}) },
           React.createElement(Components.MobileMenuSnackbar,
             
               {"frontpageUrl": "https://www.kaleva.fi", "logoUrl": "/staticfiles/londo/domains/kalevafi/site/images/kalevafi--white-logo-1x.4e0d035230d6.png"}
             
           )
         ),
         el
        );
    });
  };
  var require = function (scripts, callbackFn) {
    scripts.forEach(function(script) {
      if (!loadjs.isDefined(script)) {
        loadjs(script, script);
      }
    });
    loadjs.ready(scripts, callbackFn);
  };
  require(scripts, loadComponent);
 })();
</script>

    

    
    
      
      
<div class="__widget_RecommendationSnackbar" data-uninitialized="true"></div>

<script>
  (function() {
  var initKey = 'data-uninitialized';
  var el = document.querySelector('.__widget_RecommendationSnackbar[' + initKey + '=true]');
  el.removeAttribute(initKey);
  var scripts = ["/staticfiles/webpack_bundles/app-adfbe0952b45b845fc7b.js"];
  var loadComponent = function() {
    Loadable.preloadReady().then(function() {
      var renderMethod = el.childElementCount ? 'hydrate': 'render';
      ReactDOM[renderMethod](
        React.createElement(
          Provider,
          { store: createLocalStore({}) },
           React.createElement(Components.RecommendationSnackbar,
             
               {"channel": "kalevafi", "articleID": 4656010, "listSlug": "sinulle-ponnahtavat-suositukset", "listTitle": "Sinulle ponnahtavat suositukset", "uiEnabled": false, "mainKeyword": "asuminen"}
             
           )
         ),
         el
        );
    });
  };
  var require = function (scripts, callbackFn) {
    scripts.forEach(function(script) {
      if (!loadjs.isDefined(script)) {
        loadjs(script, script);
      }
    });
    loadjs.ready(scripts, callbackFn);
  };
  require(scripts, loadComponent);
 })();
</script>

    
  </div>

    

    <footer class="footer">
  <div class="mdc-layout-grid">
    <div class="mdc-layout-grid__inner">
      <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-3-desktop mdc-layout-grid__cell--span-4-tablet">
        <section class="footer__content">
          




  



  <div class="footer-main__wrapper">
    <ul class="footer-main-menu footer-main-menu--level-1 js-footer-main-menu">
      
  <li class="footer-main-menu__item footer-main-menu__item--level-1 footer-main-menu__item--tilaa-kaleva-2 -highlight">
    

      
        
      

      <div class="footer-main-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/tilaa-kaleva-3/?utm_source=kaleva&amp;utm_medium=sfooter&amp;utm_campaign=tam22" class="footer-main-menu__item-link footer-main-menu__item-link--level-1 footer-main-menu__item-link--tilaa-kaleva-2" target="_blank" rel="noopener">
          Tilaa Kaleva
        </a>
      

      </div>

    

    
      <ul class="footer-main-menu footer-main-menu--level-2">
        
  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--laheta-vinkki-kuva-tai-video -highlight">
    

      
        
      

      <div class="footer-main-menu__item--highlight-wrapper">

      
        
          
        
        <a href="/lukijalta/laheta" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--laheta-vinkki-kuva-tai-video" >
          Lähetä vinkki, kuva tai video
        </a>
      

      </div>

    

    
  </li>

      </ul>
    
  </li>

  <li class="footer-main-menu__item footer-main-menu__item--level-1 footer-main-menu__item--asiakaspalvelu-5 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/" class="footer-main-menu__item-link footer-main-menu__item-link--level-1 footer-main-menu__item-link--asiakaspalvelu-5" target="_blank" rel="noopener">
          Asiakaspalvelu
        </a>
      

      

    

    
      <ul class="footer-main-menu footer-main-menu--level-2">
        
  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--jata-lukijailmoitus-3 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/lukijailmoitukset/" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--jata-lukijailmoitus-3" target="_blank" rel="noopener">
          Jätä lukijailmoitus
        </a>
      

      

    

    
  </li>

  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--palvelumme-yrityksille-7 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.kalevamedia.fi/yrityksille" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--palvelumme-yrityksille-7" target="_blank" rel="noopener">
          Palvelumme yrityksille
        </a>
      

      

    

    
  </li>

  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--kaleva-media-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.kalevamedia.fi/" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--kaleva-media-2" target="_blank" rel="noopener">
          Kaleva Media
        </a>
      

      

    

    
  </li>

  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--tietosuoja-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.kalevamedia.fi/tietoa-meista/tietosuoja/" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--tietosuoja-2" target="_blank" rel="noopener">
          Tietosuoja
        </a>
      

      

    

    
  </li>

  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--kayttoehdot-4 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kayttoehdot/" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--kayttoehdot-4" target="_blank" rel="noopener">
          Käyttöehdot
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

    </ul>
  </div>

        </section>
      </div>
      <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-9-desktop mdc-layout-grid__cell--span-8-tablet">
        <section class="footer__content">
          <header class="footer__content__header">
            Ota yhteyttä
          </header>
          




  



  <div class="footer-contacts__wrapper">
    <ul class="footer-contacts-menu footer-contacts-menu--level-1 js-footer-contacts-menu">
      
  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-1 footer-contacts-menu__item--toimitus-2 -highlight">
    

      
        
      

      <div class="footer-contacts-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/yhteystiedot/#toimitus" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-1 footer-contacts-menu__item-link--toimitus-2" target="_blank" rel="noopener">
          Toimitus
        </a>
      

      </div>

    

    
      <ul class="footer-contacts-menu footer-contacts-menu--level-2">
        
  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--toimituskalevafi -normal">
    

      
        
      

      

      
        
          
        
        <a href="mailto:toimitus@kaleva.fi" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--toimituskalevafi" >
          toimitus@kaleva.fi
        </a>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--08-5377-111 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--08-5377-111">
          (08) 5377 111
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item---9 -separator">
    
      <div class="footer-contacts-menu__item-separator footer-contacts-menu__item-separator--level-2"></div>
    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--paatoimittaja-sanna-keskinen -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--paatoimittaja-sanna-keskinen">
          Päätoimittaja Sanna Keskinen
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--postiosoite -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--postiosoite">
          Postiosoite: 
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--kalevatoimitus-pl-170-90401-oulu -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--kalevatoimitus-pl-170-90401-oulu">
          Kaleva/toimitus PL 170, 90401 OULU
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--kayntiosoite -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--kayntiosoite">
          Käyntiosoite: 
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--solistinkatu-4-90140-oulu -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--solistinkatu-4-90140-oulu">
          Solistinkatu 4, 90140 OULU
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--julkaisija-kaleva365-oy-8 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--julkaisija-kaleva365-oy-8">
          Julkaisija: Kaleva365 Oy
        </span>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-1 footer-contacts-menu__item--asiakaspalvelu-6 -highlight">
    

      
        
      

      <div class="footer-contacts-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-1 footer-contacts-menu__item-link--asiakaspalvelu-6" target="_blank" rel="noopener">
          Asiakaspalvelu
        </a>
      

      </div>

    

    
      <ul class="footer-contacts-menu footer-contacts-menu--level-2">
        
  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--08-5377-610 -normal">
    

      
        
      

      

      
        
          
        
        <a href="tel:085377610" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--08-5377-610" >
          (08) 5377 610
        </a>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--mape-921-lasu-917 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--mape-921-lasu-917">
          ma–pe 9–21, la–su 9–17
        </span>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-1 footer-contacts-menu__item--palvelumme-yrityksille-6 -highlight">
    

      
        
      

      <div class="footer-contacts-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://www.kalevamedia.fi/yrityksille" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-1 footer-contacts-menu__item-link--palvelumme-yrityksille-6" target="_blank" rel="noopener">
          Palvelumme yrityksille
        </a>
      

      </div>

    

    
      <ul class="footer-contacts-menu footer-contacts-menu--level-2">
        
  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--yrityksillekalevamediafi-8 -normal">
    

      
        
      

      

      
        
          
        
        <a href="mailto:yrityksille@kalevamedia.fi" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--yrityksillekalevamediafi-8" >
          yrityksille@kalevamedia.fi
        </a>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item---17 -separator">
    
      <div class="footer-contacts-menu__item-separator footer-contacts-menu__item-separator--level-2"></div>
    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--kaleva-media-5 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--kaleva-media-5">
          Kaleva Media
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--pl-170-90401-oulu -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--pl-170-90401-oulu">
          PL 170, 90401 Oulu
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--08-5377-180-4 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--08-5377-180-4">
          08 5377 180
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--mape-klo-816 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--mape-klo-816">
          (ma–pe klo 8–16)
        </span>
      

      

    

    
  </li>

      </ul>
    
  </li>

    </ul>
  </div>

        </section>
      </div>
    </div>
  </div>
</footer>

<footer class="subfooter">
  <div class="mdc-layout-grid">
    <a href="/" class="subfooter__logo">
      <img src="/staticfiles/londo/domains/kalevafi/site/images/kalevafi--logo-2x.31853ca9aef6.png" alt="Kaleva" />
    </a>
    
    
  
  
  
  
  
<div class="subfooter__icons">
  
  <a href="https://www.facebook.com/KalevaOy" class="subfooter__icon-link">
    <i class="subfooter__icon -facebook"></i>
  </a>
  

  
  <a href="https://twitter.com/Kaleva_fi" class="subfooter__icon-link">
    <i class="subfooter__icon -twitter"></i>
  </a>
  

  
  <a href="https://www.instagram.com/kaleva_fi/" class="subfooter__icon-link">
    <i class="subfooter__icon -instagram"></i>
  </a>
  

  
  <a href="https://soundcloud.com/kaleva_fi" class="subfooter__icon-link">
    <i class="subfooter__icon -soundcloud"></i>
  </a>
  
</div>



    <div class="subfooter__ext-logos">
      
        <div class="subfooter__ext-logo">
          <img src="/staticfiles/londo/images/vastuullistajournalismia_150.44250113d663.png">
        </div>
      
    </div>
  </div>
</footer>

    <script>
      var FB_APP_ID = '499246010097508';
    </script>

    <script src="/staticfiles/webpack_bundles/common-adfbe0952b45b845fc7b.js" ></script>
    <script src="/staticfiles/webpack_bundles/consent-adfbe0952b45b845fc7b.js" ></script>
    <script type="text/javascript" src="https://cdn.jsdelivr.net/npm/lozad/dist/lozad.min.js"></script>
    <script>
      var observer = lozad('.lozad', {
        threshold: 0.1,
        rootMargin: '512px 0px 512px 0px',
        loaded: function(el) {
          el.onload = function() {
            el.dataset['complete'] = true;
          }
        }
      });
      observer.observe();
    </script>
    
    <script src="/staticfiles/londo/site/js/ie-notice.92fbe6ee0d8c.js"></script>
  </body>
</html>