






<!DOCTYPE html>




<html lang="fi">
  <head prefix="og: http://ogp.me/ns# kalevamedia: https://www.kalevamedia.fi/ns# zephr: https://www.zephr.com/ns#">
  
  <link rel="preconnect" href="https://crop.kaleva.fi">
  <link rel="preconnect" href="https://fonts.gstatic.com">
  <link rel="preconnect" href="https://googletagmanager.com">
  <link rel="preconnect" href="https://lyta.kalevamedia.fi">
  <link rel="preconnect" href="https://static.miilu.kalevakonserni.fi">
  <link rel="preconnect" href="https://sp.miilu.kalevakonserni.fi">
  <link rel="preconnect" href="https://ww2999.smartadserver.com">
  <link rel="preconnect" href="https://creatives.sascdn.com">
  <link rel="preload" href="https://ced.sascdn.com/tag/2999/smart.js" as="script">
  <link rel="preload" href="https://static.miilu.kalevakonserni.fi/consent/consent.js" as="script">
  
  <link rel="dns-prefetch" href="https://cdn.gravito.net">
  <link rel="dns-prefetch" href="https://cdn.jsdelivr.net">
  <link rel="preload" href="https://apps-cdn.relevant-digital.com/static/tags/61bc87a350fa1c66dc1b2c87.js" as="script">
  <link rel="preconnect" href="https://prg.smartadserver.com">
  <link rel="dns-prefetch" href="https://adx.adform.net">
  
    
      <script>
        window['gtag_enable_tcf_support'] = true;
        var stubScriptTag = document.createElement('script');
        stubScriptTag.innerHTML='"use strict";!function(){var e=function(){var e,t="__tcfapiLocator",a=[],n=window;for(;n;){try{if(n.frames[t]){e=n;break}}catch(e){}if(n===window.top)break;n=n.parent}e||(!function e(){var a=n.document,r=!!n.frames[t];if(!r)if(a.body){var s=a.createElement("iframe");s.style.cssText="display:none",s.name=t,a.body.appendChild(s)}else setTimeout(e,5);return!r}(),n.__tcfapi=function(){for(var e,t=arguments.length,n=new Array(t),r=0;r<t;r++)n[r]=arguments[r];if(!n.length)return a;if("setGdprApplies"===n[0])n.length>3&&2===parseInt(n[1],10)&&"boolean"==typeof n[3]&&(e=n[3],"function"==typeof n[2]&&n[2]("set",!0));else if("ping"===n[0]){var s={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof n[2]&&n[2](s)}else a.push(n)},n.addEventListener("message",(function(e){var t="string"==typeof e.data,a={};try{a=t?JSON.parse(e.data):e.data}catch(e){}var n=a.__tcfapiCall;n&&window.__tcfapi(n.command,n.version,(function(a,r){var s={__tcfapiReturn:{returnValue:a,success:r,callId:n.callId}};t&&(s=JSON.stringify(s)),e&&e.source&&e.source.postMessage&&e.source.postMessage(s,"*")}),n.parameter)}),!1))};"undefined"!=typeof module?module.exports=e:e()}();'
        document.head.appendChild(stubScriptTag)
      </script>
    
  

  <script src="/staticfiles/webpack_bundles/utils-2639a17664fccd6d8e87.js" ></script>
  <script src="/staticfiles/webpack_bundles/vimeoUtils-2639a17664fccd6d8e87.js" ></script>
    <script>
      digitalData = { 
        "channel": {
          "facebook_url": "https://www.facebook.com/KalevaOy",
          "domain": "www.kaleva.fi",
          "twitter_handle": "Kaleva_fi",
          "title": "Kaleva",
          "slug": "kalevafi",
        },
        "pageInstanceID": "5138103-prod",
        "page": {
          "category": {
            "pageType": "article",
            "primaryCategory": "kotimaa",
          },
          "attributes": {
            "accessPolicy": "premium",
            "articleLength": 13190,
            "styleTree": "basic",
            "assetID": "5138103",
            "authors": ["Hannu Toivonen"],
            "contentSourceOrganization": "Lännen Media",
            "contentSourceOrganizationExternalId": "",
            "contentSourceTitle": "Lännen media teema",
            "assetType": "journalistic",
            "genre": "Hyötyjuttu",
            "category": "Liikenne",
            "mainKeyword": "Liikennemerkit",
            "keywords": ["Teemat-Liikenne","Liikenne","Liikennemerkit","Teemat",],
            "version": 3,
            "versionID": "5367813",
            
            "visibility": "normal",
            
            
            "isPreview": false, 
            "clientType": (function() {
              var client = "Browser";
              var ua = navigator.userAgent || navigator.vendor || window.opera;
              if(ua.indexOf("FBAN") > -1) {
                client = "Facebook_app";
              }
              return client;
            })(),
            "environment": "prod"
          },
          "pageInfo": {
            "author": "Hannu Toivonen",
            "pageID": "5138103",
            "issueDate": "2022-12-04T09:00:00Z",
            
            "language": "fi-FI",
            "geoRegion": "FI",
            "publisher": "Kaleva",
            "pageTitle": "Liikennemerkkien uudistuksessa hahmoista tuli sukupuolineutraaleja – Tässä kaksi edellistä jalkakäytävän merkkiä, mutta muistatko, miltä uusin näyttää?",
            "locationProtocol": document.location.protocol.slice(0, -1),
            "locationHost": "www.kaleva.fi",
            "locationPathName": "/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103",
            "locationHref": "https://www.kaleva.fi/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103",
          },
        },
        "user": [{
          "profile": {
            "profileID": utils.getMultipassId(),
            "snowplowID": utils.getSnowplowDuid()
          },
          "signInStatus": utils.getMultipassId() ? true : false,
          "subscriberStatus": utils.getSubscriberStatus('kalevafi'),
          "activeSubscriptions": utils.getActiveSubscriptions(),
          "isTrialAllowed": utils.getIsTrialAllowed()
        }]
      };

    </script>

    <script>
    var el = document.createElement('script');
    el.type = 'application/ld+json';
    el.text = JSON.stringify({
      "@context":"https://schema.org","@type":"Organization","url":"https://" + digitalData.channel.domain + "/","sameAs":[digitalData.channel.facebook_url],"@id":"https://" + digitalData.channel.domain + "/#organization","name":digitalData.channel.title,"logo":""});
    document.querySelector('head').appendChild(el);
  </script>

    <script>
    var el = document.createElement('script');
    el.type = 'application/ld+json';
    el.text = JSON.stringify({'@context': 'http://schema.org', '@type': 'NewsArticle', 'headline': 'Liikennemerkkien uudistuksessa hahmoista tuli sukupuolineutraaleja – Tässä kaksi edellistä jalkakäytävän merkkiä, mutta muistatko, miltä uusin näyttää?', 'slug': 'liikennemerkkien-uudistuksessa-hahmoista-tuli-suku', 'description': 'Suomen liikennemerkkejä muokattiin vuonna 2020 yksinkertaisemmiksi ja selkeämmiksi. Uudistuksessa merkeistä haluttiin tehdä yhteneväisiä muiden Euroopan maiden merkkien kanssa. Ihmishahmoista tuli sukupuolettomia siinä sivussa.', 'datePublished': '2022-12-04T09:00:00+00:00', 'publisher': {'name': 'Kaleva', '@type': 'Organization', 'url': 'https://kaleva.fi'}, 'isAccessibleForFree': 'False', 'hasPart': {'@type': 'WebPageElement', 'isAccessibleForFree': 'False', 'cssSelector': '.paywall-content'}});
    document.querySelector('head').appendChild(el);
  </script>

    
    <script>
        (function() {
            function nestedAttributeExists(obj, path) {
                var pathParts = path.split('.');

                for (var i = 0; i < pathParts.length; i++) {
                    if (!obj || !obj.hasOwnProperty(pathParts[i])) {
                        return { status: false };
                    }
                    obj = obj[pathParts[i]];
                }
                return { status: true, value: obj };
            }

            var initialDataLayerObject = (function() {
                var initialData = {};
                var dateFormatter = function(date) {
                    var d = new Date(date);
                    d.setMilliseconds(0);
                    return d.toISOString().replace('.000', '');
                }
                var initialize = function(path, targetKey, defaultValue, formatter) {
                    var pathParts = path.split('.');
                    var target = pathParts[pathParts.length -1];
                    if (targetKey) {
                        target = targetKey;
                    }
                    var result = nestedAttributeExists(digitalData, path);
                    if (result.status) {
                        initialData[target] = result.value;
                    } else {
                        if (defaultValue !== undefined) {
                            initialData[target] = defaultValue;
                        }
                    }
                    if (initialData.hasOwnProperty(target) && formatter) {
                        initialData[target] = formatter(initialData[target]);
                    }
                }
                initialize('page.attributes.accessPolicy', 'accessPolicy');
                initialize('page.attributes.articleLength');
                initialize('page.attributes.styleTree');
                initialize('page.attributes.assetType', undefined, undefined, function(assetType) {
                    return assetType === 'user-generated' ? 'user' : assetType;
                });
                initialize('page.attributes.assetID');
                initialize('page.attributes.clientType');
                initialize('page.attributes.environment');
                initialize('page.category.pageType');
                initialize('page.pageInfo.author', 'authorString');
                initialize('page.attributes.authors', 'author');
                initialize('page.pageInfo.issueDate', 'publicationDate', undefined, dateFormatter);
                initialize('page.pageInfo.effectiveDate', 'modificationDate', undefined, dateFormatter);
                initialize('page.attributes.contentSourceOrganization', 'sourceOrganization');
                initialize('page.attributes.contentSourceTitle', 'sourceTitle');
                initialize('page.attributes.contentSourceOrganizationExternalId', 'sourceOrganizationExternalID');
                initialize('page.category.primaryCategory');
                initialize('page.attributes.category');
                initialize('page.attributes.genre');
                initialize('page.attributes.mainKeyword');
                initialize('page.attributes.keywords');
                if (initialData.hasOwnProperty('keywords')) {
                    initialData['keywordsString'] = initialData.keywords.join(',');
                }
                initialize('page.pageInfo.pageTitle');
                initialize('page.attributes.videoDuration');
                initialize('page.pageInfo.pageID');
                initialize('page.pageInfo.locationHref');
                initialize('channel.domain', 'channelDomain');
                initialize('channel.slug', 'channelSlug');
                initialize('page.attributes.version', 'assetVersion');
                initialize('page.attributes.versionID', 'assetVersionID');
                initialize('user.0.signInStatus', 'signInStatus');
                initialize('user.0.subscriberStatus', 'subscriberStatus');
                initialize('user.0.activeSubscriptions', 'activeSubscriptions');
                initialize('user.0.isTrialAllowed', 'isTrialAllowed');
                initialize('user.0.profile.profileID', 'userID');
                initialize('product.0.productInfo.productName');
                initialize('page.pageInfo.publisher');
                initialize('page.attributes.itemCount');
                initialize('page.attributes.itemIndex');
                initialize('page.attributes.isPreview');
                initialize('page.attributes.visibility');
                return initialData;
            })();

            window.dataLayer = [initialDataLayerObject];
        })();
    </script>


    
    <script>
      /*
        Dispatch for any events that need to be reflected in analytics.
      */
      var LorienDispatch = (function () {
        var handlers = [];
        return {
          registerEventHandler: function (handler, eventsOfInterest) {
            handlers.push({handler: handler, eventsOfInterest: eventsOfInterest});
          },
          dispatchEvent: function (event, value) {
            var i = 0;
            for (i = 0; i < handlers.length; i++) {
              if (handlers[i].eventsOfInterest.indexOf(event) > -1) {
                handlers[i].handler(event, value);
              }
            }
          }
        };
      })();

      // Event handlers
      LorienDispatch.registerEventHandler(
        function (event, value) {
          var message = false;
          if (event === 'userLogin') {
            message = {'signInStatus': value.signInStatus, 'subscriberStatus': value.subscriberStatus};
          } else {
            message = value;
            message.event = event;
          }
          if (message) {
            dataLayer.push(message);
          }
        },
        [
          "userLogin", "managedListingClick", "managedListingDisplay", "socialMediaShare",
          "virtualPageView", "managedListingItemImpression", "articleReadingPosition",
          "snowplow", "personalizedSnackbarRecommendationImpression", "audioEvent", "managedListingDismissed",
          "loginWallEvent",
        ]
      );

      LorienDispatch.registerEventHandler(function (event, value) {
          if (event === 'userLogin') {
            digitalData.user[0].signInStatus = value.signInStatus;
            digitalData.user[0].subscriberStatus = value.subscriberStatus;
          }
        },
        ["userLogin"]
      );

    </script>


    
  <script type="text/javascript">
    var SnowPlowDispatch = (function() {
      return {
        offerClaimEvent: function() {
          LorienDispatch.dispatchEvent('snowplow', {
            structuredEvent: {
              eventCategory: 'Offer Tracking',
              eventAction: 'Offer Claimed',
            },
            _clear: true,
          });
        },
        offerViewEvent: function() {
          LorienDispatch.dispatchEvent('snowplow', {
            structuredEvent: {
              eventCategory: 'Offer Tracking',
              eventAction: 'Offer Viewed',
            },
            _clear: true,
          });
        }
      };
  })()
  </script>


    
      
  
    <!-- Google Tag Manager -->
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl+ '';f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-P26833H');</script>
    <!-- End Google Tag Manager -->
  

    

    <meta charset="utf-8">
    <meta http-equiv="x-ua-compatible" content="ie=edge"><script type="text/javascript">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</script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"99670b3c8a","applicationID":"244321654","transactionName":"ZFBRMUoDCkFVBUxeX10adRBWARBbWwgXW19dUVxLSwsQVxoQUVJHQA9yFksHEGRdA08ZV1ZB","queueTime":96,"applicationTime":248,"agent":""}</script>
    <title>Liikennemerkkien uudistuksessa hahmoista tuli sukupuolineutraaleja – Tässä kaksi edellistä jalkakäytävän merkkiä, mutta muistatko, miltä uusin näyttää? | Kaleva</title>
    
    <meta name="viewport" content="width=device-width, initial-scale=1.0">

    <script src="https://cdnjs.cloudflare.com/ajax/libs/loadjs/3.5.4/loadjs.min.js"></script>
    <meta name="twitter:card" content="summary_large_image"/>
    <meta name="twitter:site" content="@Kaleva_fi" />
  <meta name="description" content="Suomen liikennemerkkejä muokattiin vuonna 2020 yksinkertaisemmiksi ja selkeämmiksi. Uudistuksessa merkeistä haluttiin tehdä yhteneväisiä muiden Euroopan maiden merkkien kanssa. Ihmishahmoista tuli sukupuolettomia siinä sivussa.">
    <meta name="robots" content="noarchive" />
    <meta property="og:title" content="Liikennemerkkien uudistuksessa hahmoista tuli sukupuolineutraaleja – Tässä kaksi edellistä jalkakäytävän merkkiä, mutta muistatko, miltä uusin näyttää?">
    <meta property="og:description" content="Suomen liikennemerkkejä muokattiin vuonna 2020 yksinkertaisemmiksi ja selkeämmiksi. Uudistuksessa merkeistä haluttiin tehdä yhteneväisiä muiden Euroopan maiden merkkien kanssa. Ihmishahmoista tuli sukupuolettomia siinä sivussa.">
    <meta property="og:url" content="https://www.kaleva.fi/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103">
    <meta property="og:image" content="https://crop.kaleva.fi/VufBGFmFr07-19la2nxGFG9PK-c=/1200x630/smart/filters:watermark(https://lorien-media-prod.s3.amazonaws.com/images/archive/2020/05/07/2020.05.07.09.07.30_watermark_kalevafi_stripe.png,repeat,-0,0):watermark(https://lorien-media-prod.s3.amazonaws.com/images/archive/2020/05/07/2020.05.07.09.06.40_watermark_kalevafi_logo.png,50,0,0)/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/11/30/2022.11.30.07.57.31_neo-7373881.jpg">
  
    <meta property="og:image:width" content="1200">
    <meta property="og:image:height" content="630">
    <meta property="og:type" content="article">
    <meta property="og:site_name" content="Kaleva">
    <meta property="fb:app_id" content="499246010097508" />
    <link rel="canonical" href="https://www.kaleva.fi/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103" />
    <meta property="og:locale" content="fi_FI">
    
  
    
    
    
      <meta property="kalevamedia:image" content="https://crop.kaleva.fi/J0lN958WEWEM0hidJnYqEAUydn8=/1290x860/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/11/30/2022.11.30.07.57.31_neo-7373881.jpg">
    
  

    

<meta name="zephr:keywords" content="teemat-liikenne, liikenne, liikennemerkit, teemat">
<meta name="zephr:access-policy" content="premium">

    
    <!--[if lt IE 9]>
      <script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
    <![endif]-->
    <script src="https://cdn.polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"></script>
    <script>window._APP_GLOBALS = {"DELIVERY_API_BASE_URL": "https://api.kalevamedia.fi", "X_API_KEY": "HSyHVnWuN96Lvm65vjoln7cFICoF4hDj65SEgsiz", "FACEBOOK_CLIENT_TOKEN": "499246010097508|db3423138889adf9535ac808b328f6a1"};</script>
    <link rel="icon" href="/staticfiles/londo/images/favicons/kalevafi.74cd970a48ae.ico">
    <link rel="stylesheet" href="https://fonts.googleapis.com/icon?family=Material+Icons">

    
      
      <link href="/staticfiles/londo/styles/main_kalevafi.fecce3e5fa9c.css" rel="stylesheet">
    

    
    
      
      
  
  <script>
    var LytaConfig = {
      site: "sites-lorien",
      debug: false,
      interstitialCookieExpiry: 60*15,
      queueAds: true,
      lazyLoadAds: true,
      uidCookieName: '__aduid',
      smart: {
        networkId: 2999,
        host: 'ww2999.smartadserver.com',
        forceSSL: false,
        siteId: 213338,
        pageId: 1142450
      },
      target: {
        adCategory: '',
        pageType : '',
        keywords: []
      }
    };
    LytaConfig.relevant = {
      enabled: true,
      scriptUrl: "https://apps-cdn.relevant-digital.com/static/tags/61bc87a350fa1c66dc1b2c87.js",
      configId: "62026411d14376cd94dbb1ca",
      stdCall: true,
    };

    if (typeof digitalData.page.attributes.keywords === 'object' && digitalData.page.attributes.keywords.length > 0) {
      LytaConfig.target.keywords = digitalData.page.attributes.keywords;
    }

    if (typeof digitalData.page.attributes.assetID === 'string') {
      LytaConfig.target.assetId = digitalData.page.attributes.assetID;
    }

    if (typeof digitalData.page.category.primaryCategory === 'string') {
      LytaConfig.target.adCategory = digitalData.page.category.primaryCategory;
    }

    if (typeof digitalData.page.attributes.clientType === 'string') {
      LytaConfig.target.clientType = digitalData.page.attributes.clientType;
    }

    if (typeof digitalData.user === 'object' && digitalData.user.length === 1) {
      LytaConfig.target.user = digitalData.user[0];
    }

    if (typeof digitalData.page.category.pageType === 'string') {
      switch (digitalData.page.category.pageType) {
        case 'Front page':
          LytaConfig.target.pageType = 'etusivu';
          break;
        case 'article':
          LytaConfig.target.pageType = 'artikkeli';
          break;
        case 'AggregationPage':
        case 'Cartoon list':
          LytaConfig.target.pageType = 'listaus';
          break;
        
        case 'video':
          LytaConfig.target.pageType = 'videot';
          break;
        default:
          LytaConfig.target.pageType = digitalData.page.category.pageType;
      }
    }
  </script>

  <script src="https://lyta.kalevamedia.fi/1.8.3/lyta.js"></script>
  

    

    
  
  
  
  
    
  
  
  <!-- Strossle SDK --><script>window.strossle=window.strossle||function(){(strossle.q=strossle.q||[]).push(arguments)};strossle('00bf6fb7-ba92-4c35-ad3d-630e6e9ff21f', '.strossle-widget');</script><script async src="https://assets.strossle.com/strossle-widget-sdk/1/strossle-widget-sdk.js"></script><!-- End Strossle SDK -->
  

  

  </head>
  <body class="">
    
    
      
  
    <!-- Google Tag Manager (noscript) -->
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P26833H"
    height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->
  

    
    
    
    <div class="drawer-menu-guardian">
      <aside class="mdc-drawer mdc-drawer--modal">
        <div class="mdc-drawer__content">
          <nav class="drawer__list">
            




  



  <div class="drawer__wrapper">
    <ul class="drawer-menu drawer-menu--level-1 js-drawer-menu">
      
  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--uutiset-2 -title">
    

      
        
      

      

      
        <span class="drawer-menu__item-title drawer-menu__item-title--level-1 drawer-menu__item-title--uutiset-2">
          Uutiset
        </span>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--etusivu-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--etusivu-2" >
          Etusivu
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--oulun-seutu-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/oulun-seutu" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--oulun-seutu-2" >
          Oulun seutu
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--pohjois-suomi-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/pohjois-suomi" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--pohjois-suomi-2" >
          Pohjois-Suomi
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--forum24-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/forum24" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--forum24-2" >
          Forum24
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kotimaa-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/kotimaa" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kotimaa-2" >
          Kotimaa
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--urheilu-3 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/urheilu" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--urheilu-3" >
          Urheilu
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kiekko-kaleva -normal">
    

      
        
      

      

      
        
          
        
        <a href="/kiekko-kaleva" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kiekko-kaleva" >
          Kiekko-Kaleva
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kaleva-live -normal">
    

      
        
      

      

      
        
          
        
        <a href="/live" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kaleva-live" >
          Kaleva Live
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--ulkomaat-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/ulkomaat" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--ulkomaat-2" >
          Ulkomaat
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kulttuuri-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/kulttuuri" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kulttuuri-2" >
          Kulttuuri
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--historia -normal">
    

      
        
      

      

      
        
          
        
        <a href="/historia" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--historia" >
          Historia
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--luonto-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/luonto" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--luonto-2" >
          Luonto
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--hyva-elama-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/hyva-elama" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--hyva-elama-2" >
          Hyvä elämä
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--ruoka -normal">
    

      
        
      

      

      
        
          
        
        <a href="/ruoka" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--ruoka" >
          Ruoka
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--koti-kaleva -normal">
    

      
        
      

      

      
        
          
        
        <a href="/koti" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--koti-kaleva" >
          Koti-Kaleva
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--oikaisut -normal">
    

      
        
      

      

      
        
          
        
        <a href="/oikaisut" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--oikaisut" >
          Oikaisut
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--haku -normal">
    

      
        
      

      

      
        
          
        
        <a href="/haku" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--haku" >
          Haku
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item---5 -separator">
    
      <div class="drawer-menu__item-separator drawer-menu__item-separator--level-1"></div>
    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--uusimmat -normal">
    

      
        
      

      

      
        
          
        
        <a href="/uutiset" class="drawer-menu__item-link drawer-menu__item-link--level-1 drawer-menu__item-link--uusimmat" >
          Uusimmat
        </a>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--galleriat-7 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/galleriat/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--galleriat-7" >
          Galleriat
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--videot-4 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/videot/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--videot-4" >
          Videot
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--lukijakuvat-ja-videot -normal">
    

      
        
      

      

      
        
          
        
        <a href="/lukijalta" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--lukijakuvat-ja-videot" >
          Lukijakuvat ja -videot
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--laheta-kuva-tai-video-3 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/lukijalta/laheta" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--laheta-kuva-tai-video-3" >
          Lähetä kuva tai video
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--podcastit-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/podcastit" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--podcastit-2" >
          Podcastit
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--sarjakuvat -normal">
    

      
        
      

      

      
        
          
        
        <a href="/sarjakuvat/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--sarjakuvat" >
          Sarjakuvat
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--ristikot-ja-sudokut-7 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/ajanviete" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--ristikot-ja-sudokut-7" >
          Ristikot ja Sudokut
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--saa-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/saa" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--saa-2" >
          Sää
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--tapahtumat-3 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://tapahtumat.kaleva.fi/fi-FI" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--tapahtumat-3" target="_blank" rel="noopener">
          Tapahtumat
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--ura -normal">
    

      
        
      

      

      
        
          
        
        <a href="/ura" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--ura" >
          Ura
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item---6 -separator">
    
      <div class="drawer-menu__item-separator drawer-menu__item-separator--level-1"></div>
    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--radio-kaleva -highlight">
    

      
        
      

      <div class="drawer-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://www.radiokaleva.fi/" class="drawer-menu__item-link drawer-menu__item-link--level-1 drawer-menu__item-link--radio-kaleva" >
          Radio Kaleva
        </a>
      

      </div>

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item---7 -separator">
    
      <div class="drawer-menu__item-separator drawer-menu__item-separator--level-1"></div>
    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--mielipiteet-2 -title">
    

      
        
      

      

      
        
          
        
        <a href="/mielipiteet" class="drawer-menu__item-title drawer-menu__item-title--level-1 drawer-menu__item-title--mielipiteet-2" >
          Mielipiteet
        </a>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--paakirjoitukset-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/paakirjoitukset" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--paakirjoitukset-2" >
          Pääkirjoitukset
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kolumnit-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/kolumnit" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kolumnit-2" >
          Kolumnit
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--lukijan-mielipide -normal">
    

      
        
      

      

      
        
          
        
        <a href="/mielipiteet" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--lukijan-mielipide" >
          Lukijan mielipide
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item---11 -separator">
    
      <div class="drawer-menu__item-separator drawer-menu__item-separator--level-1"></div>
    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--nakoislehdet-3 -title">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/" class="drawer-menu__item-title drawer-menu__item-title--level-1 drawer-menu__item-title--nakoislehdet-3" >
          Näköislehdet
        </a>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kaleva -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/kaleva/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kaleva" >
          Kaleva
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--rantalakeus -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/rantalakeus/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--rantalakeus" >
          Rantalakeus
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--siikajokilaakso -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/siikajokilaakso/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--siikajokilaakso" >
          Siikajokilaakso
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--iijokiseutu -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/iijokiseutu/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--iijokiseutu" >
          Iijokiseutu
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--pyhajokiseutu -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/pyhajokiseutu/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--pyhajokiseutu" >
          Pyhäjokiseutu
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item---14 -separator">
    
      <div class="drawer-menu__item-separator drawer-menu__item-separator--level-1"></div>
    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--kaupallinen-yhteistyo-4 -title">
    

      
        
      

      

      
        
          
        
        <a href="/kaupallinen-yhteistyo" class="drawer-menu__item-title drawer-menu__item-title--level-1 drawer-menu__item-title--kaupallinen-yhteistyo-4" >
          Kaupallinen yhteistyö
        </a>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--pohjois-pohjanmaan-yrittajat -normal">
    

      
        
      

      

      
        
          
        
        <a href="/ppy" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--pohjois-pohjanmaan-yrittajat" >
          Pohjois-Pohjanmaan yrittäjät
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--asianajo-ja-lakiasiaintoimistot -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://sivustot.kaleva.fi/asianajajat/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--asianajo-ja-lakiasiaintoimistot" target="_blank" rel="noopener">
          Asianajo- ja lakiasiaintoimistot
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--laheta-uutisvinkki-2 -highlight">
    

      
        
      

      <div class="drawer-menu__item--highlight-wrapper">

      
        
          
        
        <a href="/lukijalta/laheta" class="drawer-menu__item-link drawer-menu__item-link--level-1 drawer-menu__item-link--laheta-uutisvinkki-2" target="_blank" rel="noopener">
          Lähetä uutisvinkki
        </a>
      

      </div>

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--tilaa-kaleva-3 -highlight">
    

      
        
      

      <div class="drawer-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/tilaa-kaleva-3/?utm_source=sivusto&amp;utm_medium=kaleva&amp;utm_campaign=valikko" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--tilaa-kaleva-3" target="_blank" rel="noopener">
          Tilaa Kaleva
        </a>
      

      </div>

    

    
  </li>

      </ul>
    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-1 drawer-menu__item--asiakaspalvelu-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/" class="drawer-menu__item-link drawer-menu__item-link--level-1 drawer-menu__item-link--asiakaspalvelu-2" target="_blank" rel="noopener">
          Asiakaspalvelu
        </a>
      

      

    

    
      <ul class="drawer-menu drawer-menu--level-2">
        
  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--hallitse-tilauksiasi -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://itsepalvelu.kalevamedia.fi" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--hallitse-tilauksiasi" target="_blank" rel="noopener">
          Hallitse tilauksiasi
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--kumppaniedut -normal">
    

      
        
      

      

      
        
          
        
        <a href="/kumppaniedut" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--kumppaniedut" >
          Kumppaniedut
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--yhteystiedot-6 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/yhteystiedot/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--yhteystiedot-6" target="_blank" rel="noopener">
          Yhteystiedot
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--palvelumme-yrityksille-5 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.kalevamedia.fi/yrityksille" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--palvelumme-yrityksille-5" target="_blank" rel="noopener">
          Palvelumme yrityksille
        </a>
      

      

    

    
  </li>

  <li class="drawer-menu__item drawer-menu__item--level-2 drawer-menu__item--palaute-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/yhteystiedot/ota-yhteytta/" class="drawer-menu__item-link drawer-menu__item-link--level-2 drawer-menu__item-link--palaute-2" target="_blank" rel="noopener">
          Palaute
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

    </ul>
  </div>

          </nav>
        </div>
      </aside>
      <div class="mdc-drawer-scrim"></div>
    </div>
    
    

    
      
  <nav id="main-nav">
    <div class="main-nav__row">
      <section class="main-nav__row__section main-nav__row__section--align-start">
        
             <button class="material-icons menu top-bar-menu__navigation-icon top-bar-menu__navigation-icon--menu" >menu</button>
        
        <nav>
          




  



  <div class="top-bar__wrapper">
    <ul class="top-bar-menu top-bar-menu--level-1 js-top-bar-menu">
      
  <li class="top-bar-menu__item top-bar-menu__item--level-1 top-bar-menu__item--asiakaspalvelu-16 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/" class="top-bar-menu__item-link top-bar-menu__item-link--level-1 top-bar-menu__item-link--asiakaspalvelu-16" target="_blank" rel="noopener">
          Asiakaspalvelu
        </a>
      

      

    

    
  </li>

  <li class="top-bar-menu__item top-bar-menu__item--level-1 top-bar-menu__item--tilaa-kaleva -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/tilaa-kaleva-3/?utm_source=kaleva&amp;utm_medium=navi&amp;utm_campaign=topbar" class="top-bar-menu__item-link top-bar-menu__item-link--level-1 top-bar-menu__item-link--tilaa-kaleva" target="_blank" rel="noopener">
          Tilaa Kaleva
        </a>
      

      

    

    
  </li>

  <li class="top-bar-menu__item top-bar-menu__item--level-1 top-bar-menu__item--palvelumme-yrityksille-4 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.kalevamedia.fi/yrityksille" class="top-bar-menu__item-link top-bar-menu__item-link--level-1 top-bar-menu__item-link--palvelumme-yrityksille-4" target="_blank" rel="noopener">
          Palvelumme yrityksille
        </a>
      

      

    

    
  </li>

  <li class="top-bar-menu__item top-bar-menu__item--level-1 top-bar-menu__item--haku-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/haku" class="top-bar-menu__item-link top-bar-menu__item-link--level-1 top-bar-menu__item-link--haku-2" >
          Haku
        </a>
      

      

    

    
  </li>

    </ul>
  </div>

          
        </nav>
      </section>
      <section class="main-nav__row__section main-nav__row__section--align-end">
        
  
    <a class="top-bar-menu__item-link top-bar-menu__item-link--level-1 js-user-login-link"
      href="/leeloo/kirjaudu/?brand=kalevafi">
        <span class="material-icons top-bar-menu__navigation-icon">account_circle</span>
        <span class="top-bar-menu__item-link--navigation-text">Kirjaudu</span>
    </a>
  <script type="text/javascript">
  if (!window.Zephr) window.Zephr = {};
  if (!window.Zephr.outcomes) window.Zephr.outcomes = {};
  window.Zephr.outcomes['login-element'] = {
    featureLabel: 'zzz Login',
    outcomeId: 'graph/2#2',
    outcomeLabel: 'FeatureContentPristine'
  };
</script>

  <script type="text/javascript">
  if (!window.Zephr) window.Zephr = {};
  if (!window.Zephr.outcomes) window.Zephr.outcomes = {};
  window.Zephr.outcomes['logout-element'] = {
    featureLabel: 'zzz Logout',
    outcomeId: 'transformation/1#1',
    outcomeLabel: 'Remove'
  };
</script>


      </section>
    </div>
  </nav>


    
    
      
  
  
  
  
  
  <header id="main-header">
    <div id="main-header__row">
      <section class="main-header__section main-header__section--left">
        <div class="main-header__section--left-logo">
          <a href="/" class="main-header__logo--link">
            <img class="js-paywall-channel-logo" src="/staticfiles/londo/domains/kalevafi/site/images/kalevafi--logo-2x.31853ca9aef6.png" alt="Kaleva" />
          </a>
        </div>
        <div class="main-header__section--left-links">
          




  



  <div class="header__wrapper">
    <ul class="header-menu header-menu--level-1 js-header-menu">
      
  <li class="header-menu__item header-menu__item--level-1 header-menu__item--oulun-seutu -normal">
    

      
        
      

      

      
        
          
        
        <a href="/oulun-seutu" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--oulun-seutu" >
          Oulun seutu
        </a>
      

      

    

    
  </li>

  <li class="header-menu__item header-menu__item--level-1 header-menu__item--pohjois-suomi -normal">
    

      
        
      

      

      
        
          
        
        <a href="/pohjois-suomi" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--pohjois-suomi" >
          Pohjois-Suomi
        </a>
      

      

    

    
  </li>

  <li class="header-menu__item header-menu__item--level-1 header-menu__item--uusimmat-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/uutiset" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--uusimmat-2" >
          Uusimmat
        </a>
      

      

    

    
  </li>

  <li class="header-menu__item header-menu__item--level-1 header-menu__item--radio-kaleva-4 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.radiokaleva.fi/" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--radio-kaleva-4" target="_blank" rel="noopener">
          Radio Kaleva
        </a>
      

      

    

    
  </li>

  <li class="header-menu__item header-menu__item--level-1 header-menu__item--lukijalta-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/lukijalta" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--lukijalta-2" >
          Lukijalta
        </a>
      

      

    

    
  </li>

  <li class="header-menu__item header-menu__item--level-1 header-menu__item--nakoislehdet-4 -normal">
    

      
        
      

      

      
        
          
        
        <a href="/nakoislehdet/kaleva" class="header-menu__item-link header-menu__item-link--level-1 header-menu__item-link--nakoislehdet-4" >
          Näköislehdet
        </a>
      

      

    

    
  </li>

    </ul>
  </div>

        </div>
      </section>
      
        <section class="main-header__section main-header__section--right">
          

  <div class="weather-widget weather-widget--header">
    <iframe src="https://lw.foreca.com/v1/site/kaleva/widget-kaleva/?id=100643492&amp;name=Oulu" frameborder="0" scrolling="no" style="max-height: 100%; min-width: 100%; width: 100%"></iframe>
  </div>

        </section>
      
    </div>
  </header>

    

    
    
    
  
  <div id="interstitiaali" data-placement-id="interstitiaali" ></div>
  <script>
  try {
    Lyta.render({
      adUnit: "interstitiaali",
      async: false,
      adContainer: "interstitiaali",
      
      checkVisibility: false
    });
  }
  catch(error) {
    try {
      Lyta.log(error);
    }
    catch(logerror) {
      console.log(error);
    }
  }
  </script>
  

    
  
  <div id="mobiiliinterstitiaali" data-placement-id="mobiiliinterstitiaali" ></div>
  <script>
  try {
    Lyta.render({
      adUnit: "mobiiliinterstitiaali",
      async: false,
      adContainer: "mobiiliinterstitiaali",
      
      checkVisibility: false
    });
  }
  catch(error) {
    try {
      Lyta.log(error);
    }
    catch(logerror) {
      console.log(error);
    }
  }
  </script>
  

    
  
  <div id="erikoismainos" data-placement-id="erikoismainos" ></div>
  <script>
  try {
    Lyta.render({
      adUnit: "erikoismainos",
      async: true,
      adContainer: "erikoismainos",
      
      checkVisibility: false
    });
  }
  catch(error) {
    try {
      Lyta.log(error);
    }
    catch(logerror) {
      console.log(error);
    }
  }
  </script>
  

    
  
  <div id="mobiilierikoismainos" data-placement-id="mobiilierikoismainos" ></div>
  <script>
  try {
    Lyta.render({
      adUnit: "mobiilierikoismainos",
      async: true,
      adContainer: "mobiilierikoismainos",
      
      checkVisibility: false
    });
  }
  catch(error) {
    try {
      Lyta.log(error);
    }
    catch(logerror) {
      console.log(error);
    }
  }
  </script>
  

    

    
  
    
<div id="top-content-container">
  <div id="top-content-grid" class="mdc-drawer-app-content mdc-layout-grid mdc-theme--background">
    <div class="mdc-layout-grid__inner">
      <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-12-desktop mdc-layout-grid__cell--span-12-tablet mdc-layout-grid__cell--span-2-mobile">
        <div class="right-now-widget m-managedListing" data-managed-listing="juuri-nyt" data-widget-title="Juuri nyt">
        
          

          

          <div class="right-now-widget__item right-now-widget__item--gray">
            <a class="right-now-widget__overlay-link" href="/oysin-lasten-tehohoitoa-vaivaa-paha-hoitajapula-sa/5146314"
              data-managed-listing-item-asset-id="5146314" data-managed-listing-item-asset-version-id="5376455" data-widget-title="Juuri nyt" data-managed-listing-item-title="OYSin lasten tehohoitoa vaivaa paha hoitajapula – sairaanhoitajan mukaan se uhkaa koko yksikön olemassaoloa, jollei jotain tehdä pian" data-managed-listing-item-vignette="Tehohoito" data-managed-listing="juuri-nyt" data-managed-listing-slot-index="1" >
            </a>
            <h2 class="right-now-widget__title">
            
              <span class="right-now-widget__vignette">Tehohoito: </span>
            
            <span>OYSin lasten te­ho­hoi­toa vaivaa paha hoi­ta­ja­pu­la – sai­raan­hoi­ta­jan mukaan se uhkaa koko yksikön ole­mas­sao­loa, jollei jotain tehdä pian</span>
            </h2>
          </div>
        
          

          

          <div class="right-now-widget__item right-now-widget__item--gray">
            <a class="right-now-widget__overlay-link" href="/galleriat/vanhat-kuvat-nostalginen-joulukuu-oulussa-2002-tie/5138545"
              data-managed-listing-item-asset-id="5138545" data-managed-listing-item-asset-version-id="5368295" data-widget-title="Juuri nyt" data-managed-listing-item-title="Nos­tal­gi­nen jou­lu­kuu Oulussa 2002 – tier­na­täh­det lois­ti­vat ja Gimmel jakoi nim­ma­rei­ta Stock­man­nil­la" data-managed-listing-item-vignette="Vanhat kuvat" data-managed-listing="juuri-nyt" data-managed-listing-slot-index="2" >
            </a>
            <h2 class="right-now-widget__title">
            
              <span class="right-now-widget__vignette">Vanhat kuvat: </span>
            
            <span>Nos­tal­gi­nen jou­lu­kuu Oulussa 2002 – tier­na­täh­det lois­ti­vat ja Gimmel jakoi nim­ma­rei­ta Stock­man­nil­la</span>
            </h2>
          </div>
        
          

          

          <div class="right-now-widget__item right-now-widget__item--gray">
            <a class="right-now-widget__overlay-link" href="/kohonneet-lentolippujen-hinnat-harmittavat-oulusta/5146151"
              data-managed-listing-item-asset-id="5146151" data-managed-listing-item-asset-version-id="5376282" data-widget-title="Juuri nyt" data-managed-listing-item-title="Kohonneet lentolippujen hinnat harmittavat Oulusta Helsinkiin lentäviä, Norwegian tarkkailee tilannetta – "Pidämme reittiä tarkasti silmällä"" data-managed-listing-item-vignette="Luitko jo tämän" data-managed-listing="juuri-nyt" data-managed-listing-slot-index="3" >
            </a>
            <h2 class="right-now-widget__title">
            
              <span class="right-now-widget__vignette">Luitko jo tämän: </span>
            
            <span>Ko­hon­neet len­to­lip­pu­jen hinnat har­mit­ta­vat Oulusta Hel­sin­kiin len­tä­viä, Nor­we­gian tark­kai­lee ti­lan­net­ta – &#34;Pi­däm­me reittiä tar­kas­ti sil­mäl­lä&#34;</span>
            </h2>
          </div>
        
          <script type="text/javascript">
  if (!window.Zephr) window.Zephr = {};
  if (!window.Zephr.outcomes) window.Zephr.outcomes = {};
  window.Zephr.outcomes['right-now-widget-ad-kalevafi'] = {
    featureLabel: 'Right Now - KVA',
    outcomeId: 'graph/2#4',
    outcomeLabel: 'FeatureContentPristine'
  };
</script>
</div>
      </div>
    </div>
  </div>
</div>

  


    
    
    <div id="paraati-ad-grid" class="mdc-drawer-app-content mdc-layout-grid">
      <div class="mdc-layout-grid__inner">
        <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-12-desktop mdc-layout-grid__cell--span-12-tablet">
          <div class="ad-container ad-container--ylaparaati">
            
  
  <div id="ylaparaati" data-placement-id="ylaparaati" ></div>
  <script>
  try {
    Lyta.render({
      adUnit: "ylaparaati",
      async: true,
      adContainer: "ylaparaati",
      
      checkVisibility: true
    });
  }
  catch(error) {
    try {
      Lyta.log(error);
    }
    catch(logerror) {
      console.log(error);
    }
  }
  </script>
  

          </div>
          <div class="ad-container ad-container--mobiiliparaati">
            
  
  <div id="mobiiliylaparaati" data-placement-id="mobiiliylaparaati" ></div>
  <script>
  try {
    Lyta.render({
      adUnit: "mobiiliylaparaati",
      async: true,
      adContainer: "mobiiliylaparaati",
      
      checkVisibility: true
    });
  }
  catch(error) {
    try {
      Lyta.log(error);
    }
    catch(logerror) {
      console.log(error);
    }
  }
  </script>
  

          </div>
        </div>
      </div>
    </div>
    
    

    

    
      <div id="main-grid" class="mdc-drawer-app-content mdc-layout-grid mdc-theme--background">
        <main id="main-content">
          
  <article class="article">
    
    
  <header class="mdc-layout-grid__inner article__header">
    <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-10-desktop
                mdc-layout-grid__cell--span-12-tablet mdc-layout-grid__cell--span-2-mobile">

      <div class="article__badge-container">
  
</div>
      <div>
  
    <div class="asset__subscriber -medium -header">
      
        <div class="asset__subscriberIcon -medium -header">
          <i class="asset__subscriberIconStar -medium -header"></i>
        </div>
      
      <div class="asset__subscriberText -medium -header">
        Tilaajille
      </div>
    </div>
  
</div>
      <h1 class="article__headline">Lii­ken­ne­merk­kien uu­dis­tuk­ses­sa hah­mois­ta tuli su­ku­puo­li­neut­raa­le­ja – Tässä kaksi edel­lis­tä jal­ka­käy­tä­vän merk­kiä, mutta muis­tat­ko, miltä uusin näyt­tää?</h1>
      <h2 class="article__lead">Suomen liikennemerkkejä muokattiin vuonna 2020 yksinkertaisemmiksi ja selkeämmiksi. Uudistuksessa merkeistä haluttiin tehdä yhteneväisiä muiden Euroopan maiden merkkien kanssa. Ihmishahmoista tuli sukupuolettomia siinä sivussa.</h2>
    </div>
  </header>

    
  <section class="article__byline ">
    <div class="article__byline-separator"></div>
    <div class="article__byline-content ">
      
      <div class="article__byline-content-item article__byline-author">
        
        <div class="article__byline-author-info">
          <span class="article__byline-author-name">
            Hannu Toivonen
          </span>
          
        </div>
      </div>
      
      <div class="article__byline-content-item article__byline-share">
        
          
  
  
    
<div class="__widget_DiscussionByline" data-uninitialized="true"></div>

<script>
  (function() {
  var initKey = 'data-uninitialized';
  var el = document.querySelector('.__widget_DiscussionByline[' + initKey + '=true]');
  el.removeAttribute(initKey);
  var scripts = ["/staticfiles/webpack_bundles/app-2639a17664fccd6d8e87.js"];
  var loadComponent = function() {
    Loadable.preloadReady().then(function() {
      ReactDOM.render(
        React.createElement(
          Provider,
          { store: createLocalStore() },
           React.createElement(Components.DiscussionByline,
             
               {"discussionApiHost": "https://api.kalevamedia.fi", "appSlug": "kalevafi", "threadSlug": "article-5138103", "xApiKey": "HSyHVnWuN96Lvm65vjoln7cFICoF4hDj65SEgsiz"}
             
           )
         ),
         el
        );
    });
  };
  var require = function (scripts, callbackFn) {
    scripts.forEach(function(script) {
      if (!loadjs.isDefined(script)) {
        loadjs(script, script);
      }
    });
    loadjs.ready(scripts, callbackFn);
  };
  require(scripts, loadComponent);
 })();
</script>

  

        
        <a class="article__byline-icon -twitter share-trigger"
     href="https://twitter.com/intent/tweet?text=Liikennemerkkien%20uudistuksessa%20hahmoista%20tuli%20sukupuolineutraaleja%20%E2%80%93%20T%C3%A4ss%C3%A4%20kaksi%20edellist%C3%A4%20jalkak%C3%A4yt%C3%A4v%C3%A4n%20merkki%C3%A4%2C%20mutta%20muistatko%2C%20milt%C3%A4%20uusin%20n%C3%A4ytt%C3%A4%C3%A4%3F&url=https%3A//www.kaleva.fi/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103"
    data-share-target="twitter"></a>
  <a class="article__byline-icon -facebook share-trigger"
   href="https://www.facebook.com/sharer/sharer.php?u=https%3A//www.kaleva.fi/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103"
    data-share-target="facebook"
    data-share-quote=""
    data-share-url="https://www.kaleva.fi/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103"></a>
  <a class="article__byline-icon -whatsapp share-trigger"
   href="whatsapp://send?text=Liikennemerkkien%20uudistuksessa%20hahmoista%20tuli%20sukupuolineutraaleja%20%E2%80%93%20T%C3%A4ss%C3%A4%20kaksi%20edellist%C3%A4%20jalkak%C3%A4yt%C3%A4v%C3%A4n%20merkki%C3%A4%2C%20mutta%20muistatko%2C%20milt%C3%A4%20uusin%20n%C3%A4ytt%C3%A4%C3%A4%3F%20https%3A//www.kaleva.fi/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103"
    data-share-target="whatsapp"></a>

      </div>
      <div class="article__byline-content-item article__byline-info">
        
        <div class="article__byline_content-info--created">
          
  
    04.12.2022
  
  <i class="article__byline-icon -time"></i>
  11:00

        </div>
        <div class="article__byline_content-info--modified">
          
  
  
  

        </div>
      </div>
      
        <div class="article__byline-content-item article__byline-keywords">
          
  
  
    
      
  
    <a href="/aihe/liikennemerkit/7580" class="label__keyword label__keyword--medium">Liikennemerkit</a>
  

    
  

        </div>
      
    </div>
    <div class="article__byline-separator"></div>
  </section>


    <section class="mdc-layout-grid__inner">
      <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-7">
        
  

  
  
  

  

  <main class="article__body js-lyta-content ">
  
    <div style="position: relative;">
<div>
 <div class="article__image -size_full">
 

 
 

 

 
 

 

 
 

 

 
 
 
 
 

 
 

 
 
 
 
 
 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 <div class="responsive-image-wrapper aspect-box -ratio_original " style="padding-top: 52.15449290593799%">
 
 
 <img class="responsive-image article__image-image lozad" data-srcset="https://crop.kaleva.fi/ux_PP0cq31hQA_VP79u11DkMpCQ=/100x52/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/11/30/2022.11.30.07.57.54_neo-7373898.jpg 100w, https://crop.kaleva.fi/W4LrYyMRZmlkty_DI4xGxoqusmA=/400x209/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/11/30/2022.11.30.07.57.54_neo-7373898.jpg 400w, https://crop.kaleva.fi/ns6Rl5pyPT6Hw2mDovuyIXkd4-0=/800x417/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/11/30/2022.11.30.07.57.54_neo-7373898.jpg 800w, https://crop.kaleva.fi/mU6XyzxQWaIjqYTxS9RBVgYAZcE=/1400x730/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/11/30/2022.11.30.07.57.54_neo-7373898.jpg 1400w, https://crop.kaleva.fi/qt70TyreQw68uk8o4xPRthFEhoI=/2600x1356/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/11/30/2022.11.30.07.57.54_neo-7373898.jpg 2600w" sizes="(max-width:768px) 767px, (max-width:1024px) 556px, 740px" data-src="https://crop.kaleva.fi/qt70TyreQw68uk8o4xPRthFEhoI=/2600x1356/smart/https%3A//lorien-media-prod.s3.amazonaws.com/images/archive/2022/11/30/2022.11.30.07.57.54_neo-7373898.jpg" alt="Aikaisemmin monet liikennemerkit olivat yksityiskohtaisempia kuin nykyään. Vasemmalla oleva jalkakäytävää osoittava merkki otettiin käyttöön vuonna 1957. Oikeanpuoleinen oli käytössä 1900-luvun lopulla ja 2000-luvulla ennen kaksi vuotta sitten tehtyä liikennemerkkiuudistusta.">
 </div>
 

 
 
 
 
 <div class="article__image-texts">
 
 <div class="article__image-caption">
 Aikaisemmin monet liikennemerkit olivat yksityiskohtaisempia kuin nykyään. Vasemmalla oleva jalkakäytävää osoittava merkki otettiin käyttöön vuonna 1957. Oikeanpuoleinen oli käytössä 1900-luvun lopulla ja 2000-luvulla ennen kaksi vuotta sitten tehtyä liikennemerkkiuudistusta.
</div></div></div></div><div style="height: 100%;
    max-height: 250px;
    position: absolute;
    width: 100%;
    bottom: 0;
    background-image: linear-gradient(0deg, #fff 0%, rgba(255, 255, 255, 0) 100%);"></div>
</div><style>
  /* STYLES ONLY FOR PAYWALL ************************************************************/
  .paywall-css-container.-type-pay {
    background-color: var(--zephr-channel-color-light);
    --zephr-checkmark-color: var(--zephr-channel-color-main);
    --zephr-underline-color: var(--zephr-channel-color-main);
    --zephr-horizontal-line-color: var(--zephr-channel-color-main);
  }

  .paywall-css-container .paywall__icon.-type-pay {
    fill: var(--zephr-channel-color-main);
  }

  .paywall-css-container.-type-pay .paywall__icon.-type-login {
    display: none;
  }

  .svg-icon-circle {
    stroke: var(--zephr-channel-color-main);
  }

  .svg-icon-star {
    fill: var(--zephr-channel-color-main);
  }

  .paywall-css-container .paywall__cta,
  .paywall-css-container.-type-login .paywall__cta-login {
    padding: 11px 50px;
    font-size: 18px;
    text-align: center;
    margin-bottom: 0;
    border-radius: 100px;
  }

  .paywall-css-container.-type-login .paywall__cta-login {
    padding: 9xp 50px;
  }

  .paywall-css-container.type-pay .paywall__cta {
    margin-bottom: 35px;
  }

  .paywall-css-container.-type-pay.-theme-dark {
    background-color: var(--zephr-channel-color-dark);
  }

  .paywall-css-container.-type-pay.-theme-black {
    background-color: #000;
  }

  .paywall-css-container.-type-pay.-theme-dark *,
  .paywall-css-container.-type-pay.-theme-black * {
    color: white;
  }

  .paywall-css-container.-type-pay.-theme-dark .paywall__channel-logo,
  .paywall-css-container.-type-pay.-theme-black .paywall__channel-logo {
    filter: brightness(0) invert(1);
  }

  @media screen and (min-width: 500px) {
    .paywall-css-container .paywall__cta,
    .paywall-css-container.-type-login .paywall__cta-login {
      padding: 18px 60px;
      font-size: 22px;
      line-height: 24px;
    }
    .paywall-css-container.-type-login .paywall__cta-login {
      padding: 16px 60px;
    }
  }
</style>

<style>
  /* STYLES ONLY FOR LOGINWALL ********************************************************/
  .paywall-css-container.-type-login {
    background-color: var(--zephr-km-color-3);
    --zephr-checkmark-color: var(--zephr-km-color-1);
    --zephr-underline-color: var(--zephr-km-color-1);
    --zephr-horizontal-line-color: var(--zephr-km-color-1);
  }

  .paywall-css-container.-type-login .paywall__icon.-type-pay {
    display: none;
  }

  .paywall__button-container {
    display: flex;
    flex-direction: column;
    align-self: center;
  }
</style>

<style>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</style>

<div class="paywall-css-container -type-pay -theme-">
  <div class="paywall__header">
    <svg
      class="paywall__icon -type-pay"
      width="100%"
      height="100%"
      viewBox="0 0 60 60"
      version="1.1"
      xmlns="http://www.w3.org/2000/svg"
      xmlns:xlink="http://www.w3.org/1999/xlink"
    >
      <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <circle class="svg-icon-circle" stroke-width="3" fill="#FFFFFF" cx="30" cy="30" r="28.5"></circle>
        <g class="svg-icon-star" transform="translate(14.500000, 14.000000)" fill-rule="nonzero">
          <path
            d="M32,11.8269231 C32,12.1089744 31.8333333,12.4166667 31.5,12.75 L24.5192308,19.5576923 L26.1730769,29.1730769 C26.1858974,29.2628205 26.1923077,29.3910256 26.1923077,29.5576923 C26.1923077,29.8269231 26.125,30.0544872 25.9903846,30.2403846 C25.8557692,30.4262821 25.6602564,30.5192308 25.4038462,30.5192308 C25.1602564,30.5192308 24.9038462,30.4423077 24.6346154,30.2884615 L16,25.75 L7.36538462,30.2884615 C7.08333333,30.4423077 6.82692308,30.5192308 6.59615385,30.5192308 C6.32692308,30.5192308 6.125,30.4262821 5.99038462,30.2403846 C5.85576923,30.0544872 5.78846154,29.8269231 5.78846154,29.5576923 C5.78846154,29.4807692 5.80128205,29.3525641 5.82692308,29.1730769 L7.48076923,19.5576923 L0.480769231,12.75 C0.16025641,12.4038462 0,12.0961538 0,11.8269231 C0,11.3525641 0.358974359,11.0576923 1.07692308,10.9423077 L10.7307692,9.53846154 L15.0576923,0.788461538 C15.3012821,0.262820513 15.6153846,0 16,0 C16.3846154,0 16.6987179,0.262820513 16.9423077,0.788461538 L21.2692308,9.53846154 L30.9230769,10.9423077 C31.6410256,11.0576923 32,11.3525641 32,11.8269231 Z"
            id="Path"
          ></path>
        </g>
      </g>
    </svg>
    <svg
      class="paywall__icon -type-login"
      width="60px"
      height="60px"
      viewBox="0 0 60 60"
      version="1.1"
      xmlns="http://www.w3.org/2000/svg"
      xmlns:xlink="http://www.w3.org/1999/xlink"
    >
      <g id="Icons/Kirjautuneet_1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <circle id="Oval" fill="#8B784A" cx="30" cy="30" r="30"></circle>
        <g id="-copy" transform="translate(10.000000, 10.000000)" fill="#FFFFFF" fill-rule="nonzero">
          <path
            d="M0,20 C0,23.6021509 0.900538045,26.9354839 2.7016129,30 C4.50268776,33.0645161 6.93548387,35.4973122 10,37.2983871 C13.0645161,39.099462 16.3978491,40 20,40 C23.6021509,40 26.9354839,39.099462 30,37.2983871 C33.0645161,35.4973122 35.4973122,33.0645161 37.2983871,30 C39.099462,26.9354839 40,23.6021509 40,20 C40,16.3978491 39.099462,13.0645161 37.2983871,10 C35.4973122,6.93548387 33.0645161,4.50268776 30,2.7016129 C26.9354839,0.900538045 23.6021509,0 20,0 C16.3978491,0 13.0645161,0.900538045 10,2.7016129 C6.93548387,4.50268776 4.50268776,6.93548387 2.7016129,10 C0.900538045,13.0645161 0,16.3978491 0,20 Z M5.80645161,30.1612903 C5.96774194,29.0860219 6.41129032,28.13172 7.13709677,27.2983871 C7.86290323,26.4650542 8.76344127,25.9139781 9.83870968,25.6451613 L12.4193548,24.9193548 C14.6236555,26.8010749 17.150538,27.7419355 20,27.7419355 C22.849462,27.7419355 25.3763445,26.8010749 27.5806452,24.9193548 L30.1612903,25.6451613 C31.2365587,25.9139781 32.1370968,26.4650542 32.8629032,27.2983871 C33.5887097,28.13172 34.0322581,29.0860219 34.1935484,30.1612903 C32.5806452,32.4193548 30.5241935,34.1935484 28.0241935,35.483871 C25.5241935,36.7741935 22.849462,37.4193548 20,37.4193548 C17.150538,37.4193548 14.4758065,36.7741935 11.9758065,35.483871 C9.47580645,34.1935484 7.41935484,32.4193548 5.80645161,30.1612903 Z M10.9677419,16.1290323 C10.9677419,14.516129 11.3709677,13.0107523 12.1774194,11.6129032 C12.983871,10.2150542 14.0860219,9.11290323 15.483871,8.30645161 C16.88172,7.5 18.3870968,7.09677419 20,7.09677419 C21.6129032,7.09677419 23.11828,7.5 24.516129,8.30645161 C25.9139781,9.11290323 27.016129,10.2150542 27.8225806,11.6129032 C28.6290323,13.0107523 29.0322581,14.516129 29.0322581,16.1290323 C29.0322581,17.7419355 28.6290323,19.2473122 27.8225806,20.6451613 C27.016129,22.0430103 25.9139781,23.1451613 24.516129,23.9516129 C23.11828,24.7580645 21.6129032,25.1612903 20,25.1612903 C18.3870968,25.1612903 16.88172,24.7580645 15.483871,23.9516129 C14.0860219,23.1451613 12.983871,22.0430103 12.1774194,20.6451613 C11.3709677,19.2473122 10.9677419,17.7419355 10.9677419,16.1290323 Z"
            id="Shape"
          ></path>
        </g>
      </g>
    </svg>
  </div>
  <h1 class="paywall__main-title a-heading__3">Lue Digiä 1 kk _vain 1 €_</h1>
  <h2 class="paywall__subtitle a-paragraph__1">Tutustu, voit peruuttaa tilauksen koska tahansa.</h2>

  <div class="paywall__benefits" style="display: none"></div>

  <div class="paywall__cta-button-stretcher">
    <div class="paywall__cta--container">
      <a
        class="paywall__cta a-button-primary no-link-styles js-cta-link js-create-account-link js-parent-frame-link"
        href="https://kampanjat.kalevamedia.fi/kaleva-1kk-1euro/"
        >TUTUSTU TÄSTÄ</a
      >
    </div>

    <div class="paywall__benefits--horizontal" style="display: none"></div>

    <img class="paywall__channel-logo" />

    <p class="a-paragraph__2 paywall__cta-login--container">
      <span class="paywall__cta-login-text-before">Oletko jo tilaaja?</span>
      <a class="paywall__cta-login js-login-link js-parent-frame-link" href="/leeloo/kirjaudu/?brand&#61;kalevafi"
        >Kirjaudu sisään.</a
      >
    </p>
  </div>
</div>

<script>
  const isProd = digitalData.page.attributes.environment === 'prod';
  window.dataLayer = window.dataLayer || [];
  window.dataLayer.push({
    useZephr: true,
  });

  // This is a collection of utilities that both walls use. This is copy-paste from Londo and the
  // iframe implementations served from mpcdn. TODO: setup bundling, separate into multiple files.
  window.KalevaPaywallUtils = {
    generateTransactionId: function generateTransactionId() {
      var base36Timestamp = Date.now().toString(36);
      var MAX_INT = Math.pow(2, 53) - 1;
      var base36RandomInt = Math.floor(Math.random() * MAX_INT).toString(36);
      return base36Timestamp + base36RandomInt;
    },
    getUtmParams: function getUtmParams() {
      var utmParams = ['utm_source', 'utm_medium', 'utm_campaign', 'utm_content', 'utm_term'],
        utmQuery = decodeURIComponent(window.location.search.substring(1)),
        utmVariables = utmQuery.split('&'),
        paramsOfIntrest = utmVariables.filter(function (utmVariable) {
          var param = utmVariable.split('=');
          if (utmParams.indexOf(param[0]) !== -1 && param[1]) {
            return utmVariable;
          }
        });
      if (paramsOfIntrest) {
        return paramsOfIntrest.join('&');
      }
      return '';
    },
    setUrlParameter: function setUrlParameter(url, key, value) {
      // https://blog.bitscry.com/2018/08/17/getting-and-setting-url-parameters-with-javascript/
      var key = encodeURIComponent(key),
        value = value ? encodeURIComponent(value) : value;

      var baseUrl = url.split('?')[0],
        newParam = key + '=' + value,
        params = '?' + newParam,
        urlQueryString = '';

      if (url.split('?')[1] !== undefined) {
        urlQueryString = '?' + url.split('?')[1];
      }

      // If the "search" string exists, then build params from it
      if (urlQueryString) {
        var updateRegex = new RegExp('([\?&])' + key + '[^&]*');
        var removeRegex = new RegExp('([\?&])' + key + '=[^&;]+[&;]?');

        if (value === undefined || value === null || value === '') {
          // Remove param if value is empty
          params = urlQueryString.replace(removeRegex, '$1');
          params = params.replace(/[&;]$/, '');
        } else if (urlQueryString.match(updateRegex) !== null) {
          // If param exists already, update it
          params = urlQueryString.replace(updateRegex, '$1' + newParam);
        } else if (urlQueryString == '') {
          // If there are no query strings
          params = '?' + newParam;
        } else {
          // Otherwise, add it to end of query string
          params = urlQueryString + '&' + newParam;
        }
      }

      // no parameter was set so we don't need the question mark
      params = params === '?' ? '' : params;

      return baseUrl + params;
    },
    getLoginwallUrlParams: function getLoginwallUrlParams(source, campaign, trxId) {
      const utmParams = `&utm_medium=paywall&utm_source=${source}&utm_campaign=${campaign}`;
      const logintxidParam = `logintxid=${trxId}`;
      const sep = `?`;
      const nextParam = `&next=${encodeURIComponent(
        window.location.pathname + window.location.search + sep + logintxidParam + utmParams,
      )}`;
      return `${nextParam}&${logintxidParam}${utmParams}`;
    },
  };
</script>

<script>
  // LOGINWALL JS FROM LONDO
  (function () {
    const CALLBACK_MAX_WAIT = 3000;
    const CALLBACK_EVENT_TIMEOUT = 2000;
    const CALLBACK_DELAY = 300;

    const trackLoginPaywallEvent = (action, cb) => {
      if (window.LorienDispatch) {
        const payload = {
          structuredEvent: {
            eventCategory: 'Funnel Tracking',
            eventAction: action,
          },
        };
        if (typeof cb === 'function') {
          // Never wait longer than CALLBACK_MAX_WAIT
          setTimeout(() => {
            cb();
          }, CALLBACK_MAX_WAIT);
          payload.eventTimeout = CALLBACK_EVENT_TIMEOUT;
          payload.eventCallback = cb;
        }
        window.LorienDispatch.dispatchEvent('loginWallEvent', payload);
      } else if (typeof cb === 'function') {
        cb();
      }
    };

    const trackLoginWallClick = (elem, action) => {
      elem.addEventListener('click', function (event) {
        event.preventDefault();
        const url = event.currentTarget.href;
        const callbackToRedirectUser = () => {
          setTimeout(() => {
            window.location.href = url;
          }, CALLBACK_DELAY);
        };
        trackLoginPaywallEvent(action, callbackToRedirectUser);
      });
    };

    const loginRequiredPaywall = (options) => {
      const trxId = KalevaPaywallUtils.generateTransactionId();
      const pwCreateLink = document.querySelector('.js-create-account-link');
      const pwLoginLink = document.querySelector('.js-login-link');
      const createLinkUrlParams = KalevaPaywallUtils.getLoginwallUrlParams(
        options.channel,
        'login-paywall-signup',
        trxId,
      );
      if (pwCreateLink.href.includes('luotunnus')) {
        pwCreateLink.href = pwCreateLink.href + createLinkUrlParams;
      } else {
        const newParams = createLinkUrlParams.replace(
          'next=',
          'content_url=' + encodeURIComponent(window.location.origin),
        );
        const hasParams = pwCreateLink.href.includes('?');
        pwCreateLink.href = pwCreateLink.href + (hasParams ? newParams : newParams.replace('&', '?'));
      }
      const loginLinkUrl =
        pwLoginLink.href + KalevaPaywallUtils.getLoginwallUrlParams(options.channel, 'login-paywall-logins', trxId);
      pwLoginLink.href = loginLinkUrl;

      window.dataLayer.push({
        logintxid: trxId,
      });

      trackLoginPaywallEvent('Login Walled Page Landed');
      trackLoginWallClick(pwCreateLink, 'Signup link clicked');
      trackLoginWallClick(pwLoginLink, 'Login link clicked');
    };

    window.login_html_utils = {
      loginRequiredPaywall,
    };
  })();

  function initLoginwall() {
    !isProd && console.log('initLoginwall');
    // old implementation
    window.login_html_utils.loginRequiredPaywall({
      channel: window.digitalData.channel.title,
    });

    // new zephr stuff
    const darkTheme = ['body.videosite', 'body.gallery', '.article.-rich'].some((cls) => document.querySelector(cls));
    document.querySelector('.paywall__cta').classList.add('km-button-rounded');
    document.querySelector('.paywall__cta').classList.add('km-button-rounded__brown');
    document.querySelector('.js-login-link').classList.add('no-link-styles');
    document.querySelector('.js-login-link').classList.add('km-button-rounded');
    document
      .querySelector('.js-login-link')
      .classList.add(darkTheme ? 'km-button-rounded__black-outlined' : 'km-button-rounded__white-outlined');
    document.querySelector('.paywall-css-container').classList.add(darkTheme ? '-theme-dark' : '-theme-normal');
    if (darkTheme) {
      document.querySelector('.article.-rich')?.classList.add('-with-paywall-dark');
    }
  }
</script>

<script>
  // PAYWALL JS, mpcdn paywall.js

  function initPaywall() {
    !isProd && console.log('initPaywall');
    // Below is a ~copy-paste of KalevaPaywall.init(). TODO: cleaning
    const searchParams = new URLSearchParams(document.location.search);
    const kvatxid = searchParams.get('kvatxid') || KalevaPaywallUtils.generateTransactionId();

    const paywallSlug = `${window.digitalData.channel.slug}-paywall`;
    window.dataLayer = window.dataLayer || [];
    window.dataLayer.push({
      event: 'Paywall hit',
      paywallSlug: paywallSlug,
      kvatxid: kvatxid,
    });

    const ctaLink = document.querySelector('a.js-cta-link');

    // replicate utm params
    new URLSearchParams(KalevaPaywallUtils.getUtmParams()).forEach((value, key) => {
      ctaLink.href = KalevaPaywallUtils.setUrlParameter(ctaLink.href, key, value);
    });

    const currentUrlWithKvatxid = KalevaPaywallUtils.setUrlParameter(document.location.href, 'kvatxid', kvatxid);

    ctaLink.href = KalevaPaywallUtils.setUrlParameter(ctaLink.href, 'kvatxid', kvatxid);
    ctaLink.href = KalevaPaywallUtils.setUrlParameter(ctaLink.href, 'content_url', currentUrlWithKvatxid);

    const loginLink = document.querySelector('a.js-login-link');
    if (loginLink) {
      loginLink.href = KalevaPaywallUtils.setUrlParameter(loginLink.href, 'next', currentUrlWithKvatxid);
    }

    // KalevaPaywallContent.bindListeners();
    const parentFrameLinks = document.querySelectorAll('a.js-parent-frame-link');
    Array.prototype.forEach.call(parentFrameLinks, function (element) {
      element.addEventListener('click', function (e) {
        e.preventDefault();
        if (e.target.className.indexOf('js-cta-link') > -1) {
          window.dataLayer.push({
            event: 'Paywall CTA click',
          });
          setTimeout(function () {
            document.location.href = e.target.getAttribute('href');
          }, 100);
        } else {
          document.location.href = e.target.getAttribute('href');
        }
      });
    });
  }
</script>

<script>
  // SHARED JS
  function addBenefits(containerClass, iconClass, benefits) {
    if (benefits) {
      const container = document.querySelector(containerClass);
      container.style.display = '';
      benefits
        .split('&#10;')
        .map((t) => t.trim())
        .filter(Boolean)
        .forEach((benefit) => {
          container.innerHTML += `
        <div class="a-paragraph__2 paywall__benefits--benefit">
          <i class="fas ${iconClass} paywall__benefits--icon"></i><span class="paywall__benefits--text">${benefit}</span>
        </div>`;
        });
    }
  }

  function addSpanToSelector(splitter, spanClass) {
    return function adder(selector) {
      function addToSingle(elem) {
        if (elem.innerHTML.includes(spanClass)) return;
        const parts = elem.innerHTML.split(splitter);
        if (parts.length > 1 && parts.length % 2 === 1) {
          const result = parts.map((part, idx) => (idx % 2 === 1 ? `<span class="${spanClass}">${part}</span>` : part));
          elem.innerHTML = result.join('');
        }
      }

      const elems = document.querySelectorAll(selector);
      if (elems.length) {
        Array.from(elems).forEach((elem) => addToSingle(elem));
      }
    };
  }

  const addUnderline = addSpanToSelector('_', 'paywall__span-underline');
  const addBold = addSpanToSelector('*', 'paywall__span-bold');

  function init() {
    const isPay = document.querySelector('.paywall-css-container').classList.value.includes('-type-pay');
    !isProd && console.log('init()::type', isPay ? 'pay' : 'login');
    setTimeout(() => {
      if (isPay) {
        initPaywall();
      } else {
        initLoginwall();
      }
    }, 0);

    setTimeout(() => {
      addBenefits('.paywall__benefits', 'fa-check', '');
      addBenefits('.paywall__benefits--horizontal', 'fa-check-circle', 'Tilauksella pääset lukemaan rajoituksetta tämän ja muita kiinnostavia artikkeleita');
    }, 0);

    setTimeout(() => {
      if (isPay) {
        const richArticleLogo = document.querySelector('.mainHeaderOpenLogo.js-paywall-channel-logo');
        const channelLogo = document.querySelector('.js-paywall-channel-logo');
        document.querySelector('.paywall-css-container .paywall__channel-logo').src = (
          richArticleLogo || channelLogo
        ).src;
      }
    }, 0);

    setTimeout(() => {
      [
        '.paywall__main-title',
        '.paywall__subtitle',
        '.paywall__benefits--text',
        '.paywall__cta-login-text-before',
        '.js-login-link',
      ].forEach((name) => {
        addUnderline(name);
        addBold(name);
      });
    }, 0);
  }

  if (document.querySelector('.paywall-css-container .paywall__main-title') || document.readyState === 'complete') {
    init();
  } else {
    window.addEventListener('load', init);
  }
</script>
<script type="text/javascript">
  if (!window.Zephr) window.Zephr = {};
  if (!window.Zephr.outcomes) window.Zephr.outcomes = {};
  window.Zephr.outcomes['paywall-kalevafi'] = {
    featureLabel: 'Content - KVA',
    outcomeId: 'transformation/4',
    outcomeLabel: 'Article pw 1 e 1 month'
  };
</script>

  
  </main>

    <div id="puff-container">
  <p class="aligncenter">
<a href="https://asiakaspalvelu.kaleva.fi/kaleva/kaleva-sovellus/">
<img border="0" alt="Sovellus" src="https://d3f5ute1xnzkw4.cloudfront.net/wp-content/uploads/sites/105/2022/04/14094026/Kaleva-sovellus.jpg" width="auto" height="auto" class="center">
</a>
 </div><script type="text/javascript">
  if (!window.Zephr) window.Zephr = {};
  if (!window.Zephr.outcomes) window.Zephr.outcomes = {};
  window.Zephr.outcomes['below-article-kalevafi'] = {
    featureLabel: 'Below article - KVA',
    outcomeId: 'transformation/1',
    outcomeLabel: 'KVA Sovellus'
  };
</script>

  <div class="asset__bottom-meta">
          <div class="asset__bottom-meta-row -icons">
            
  
  
    
<div class="__widget_DiscussionButton" data-uninitialized="true"></div>

<script>
  (function() {
  var initKey = 'data-uninitialized';
  var el = document.querySelector('.__widget_DiscussionButton[' + initKey + '=true]');
  el.removeAttribute(initKey);
  var scripts = ["/staticfiles/webpack_bundles/app-2639a17664fccd6d8e87.js"];
  var loadComponent = function() {
    Loadable.preloadReady().then(function() {
      ReactDOM.render(
        React.createElement(
          Provider,
          { store: createLocalStore() },
           React.createElement(Components.DiscussionButton,
             
               {"discussionApiHost": "https://api.kalevamedia.fi", "appSlug": "kalevafi", "threadSlug": "article-5138103", "xApiKey": "HSyHVnWuN96Lvm65vjoln7cFICoF4hDj65SEgsiz"}
             
           )
         ),
         el
        );
    });
  };
  var require = function (scripts, callbackFn) {
    scripts.forEach(function(script) {
      if (!loadjs.isDefined(script)) {
        loadjs(script, script);
      }
    });
    loadjs.ready(scripts, callbackFn);
  };
  require(scripts, loadComponent);
 })();
</script>

  

            <div class="asset__bottom-meta-item -share">
              <a class="asset__bottom-meta-icon -twitter share-trigger"
     href="https://twitter.com/intent/tweet?text=Liikennemerkkien%20uudistuksessa%20hahmoista%20tuli%20sukupuolineutraaleja%20%E2%80%93%20T%C3%A4ss%C3%A4%20kaksi%20edellist%C3%A4%20jalkak%C3%A4yt%C3%A4v%C3%A4n%20merkki%C3%A4%2C%20mutta%20muistatko%2C%20milt%C3%A4%20uusin%20n%C3%A4ytt%C3%A4%C3%A4%3F&url=https%3A//www.kaleva.fi/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103"
    data-share-target="twitter"></a>
  <a class="asset__bottom-meta-icon -facebook share-trigger"
   href="https://www.facebook.com/sharer/sharer.php?u=https%3A//www.kaleva.fi/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103"
    data-share-target="facebook"
    data-share-quote=""
    data-share-url="https://www.kaleva.fi/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103"></a>
  <a class="asset__bottom-meta-icon -whatsapp share-trigger"
   href="whatsapp://send?text=Liikennemerkkien%20uudistuksessa%20hahmoista%20tuli%20sukupuolineutraaleja%20%E2%80%93%20T%C3%A4ss%C3%A4%20kaksi%20edellist%C3%A4%20jalkak%C3%A4yt%C3%A4v%C3%A4n%20merkki%C3%A4%2C%20mutta%20muistatko%2C%20milt%C3%A4%20uusin%20n%C3%A4ytt%C3%A4%C3%A4%3F%20https%3A//www.kaleva.fi/liikennemerkkien-uudistuksessa-hahmoista-tuli-suku/5138103"
    data-share-target="whatsapp"></a>

            </div>
          </div>
          
  <div class="asset__bottom-meta-row">
    <div class="asset__bottom-meta-item -keywords">
      
  
    
  
    <a href="/aihe/liikennemerkit/7580" class="badge__keyword badge__keyword--light">Liikennemerkit</a>
  

  
  
    
  
    <a href="/aihe/teemat-liikenne/49231" class="badge__keyword badge__keyword--light">Teemat-Liikenne</a>
  

  
    
  
    <a href="/aihe/liikenne/6" class="badge__keyword badge__keyword--light">Liikenne</a>
  

  
    
  
    <a href="/aihe/teemat/30090" class="badge__keyword badge__keyword--light">Teemat</a>
  

  

    </div>
  </div>

        </div>
        <div class="article__bottom-separator"></div>

        
  
    
    
    
    
    
      
<div class="__widget_TabbedContentWidget" data-uninitialized="true"></div>

<script>
  (function() {
  var initKey = 'data-uninitialized';
  var el = document.querySelector('.__widget_TabbedContentWidget[' + initKey + '=true]');
  el.removeAttribute(initKey);
  var scripts = ["/staticfiles/webpack_bundles/app-2639a17664fccd6d8e87.js"];
  var loadComponent = function() {
    Loadable.preloadReady().then(function() {
      ReactDOM.render(
        React.createElement(
          Provider,
          { store: createLocalStore() },
           React.createElement(Components.TabbedContentWidget,
             
               {"title": "Lue lis\u00e4\u00e4", "imageFormat": "square", "imageSize": 100, "wrapClass": "content-widget--related-content -article", "tabs": [{"title": "Uusimmat", "query": "/api/v2/channels/kalevafi/contents/5138103/recommendations/?limit=5&asset_type=&omit=article.content%2Cgallery.items"}], "ugcRibbonVersion": "small"}
             
           )
         ),
         el
        );
    });
  };
  var require = function (scripts, callbackFn) {
    scripts.forEach(function(script) {
      if (!loadjs.isDefined(script)) {
        loadjs(script, script);
      }
    });
    loadjs.ready(scripts, callbackFn);
  };
  require(scripts, loadComponent);
 })();
</script>

    
  


        
          <div class="ad-container ad-container--mobile-content">
            
  
  <div id="belowcontent" data-placement-id="belowcontent" class="lyta-lazy-load"></div>
  <script>
  try {
    Lyta.render({
      adUnit: "belowcontent",
      async: true,
      adContainer: "belowcontent",
      
      checkVisibility: true
    });
  }
  catch(error) {
    try {
      Lyta.log(error);
    }
    catch(logerror) {
      console.log(error);
    }
  }
  </script>
  

          </div>
          <div class="ad-separator"></div>
        
      </div>
      <aside class="mdc-layout-grid__cell mdc-layout-grid__cell--span-5 sidebar__column-container">
        
          
          <div class="sidebar__column-item -ad -ad1">
            <div class="sidebar-sticky-container">
              <div class="ad-container ad-container--sidebar">
                
  
  <div id="sidebar1" data-placement-id="sidebar1" ></div>
  <script>
  try {
    Lyta.render({
      adUnit: "sidebar1",
      async: true,
      adContainer: "sidebar1",
      
      checkVisibility: true
    });
  }
  catch(error) {
    try {
      Lyta.log(error);
    }
    catch(logerror) {
      console.log(error);
    }
  }
  </script>
  

              </div>
            </div>
          </div>

          
        
      </aside>
    </section>
    
  </article>

  
    
  
  <section class="mdc-layout-grid__inner">
    <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-12-desktop mdc-layout-grid__cell--span-12-tablet">
      <div class="strossle-container">
        <div class="strossle-widget"></div>
      </div>
    </div>
  </section>

  <div class="article-middle">
    <div class="article-middle__separator"></div>
  </div>
  

  

  <section class="mdc-layout-grid__inner">
    <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-7 discussion-container">
      
        
  
  
  
  <div id="kommentit">
    
      
<div class="__widget_Discussion" data-uninitialized="true"></div>

<script>
  (function() {
  var initKey = 'data-uninitialized';
  var el = document.querySelector('.__widget_Discussion[' + initKey + '=true]');
  el.removeAttribute(initKey);
  var scripts = ["/staticfiles/webpack_bundles/app-2639a17664fccd6d8e87.js"];
  var loadComponent = function() {
    Loadable.preloadReady().then(function() {
      ReactDOM.render(
        React.createElement(
          Provider,
          { store: createLocalStore() },
           React.createElement(Components.Discussion,
             
               {"discussionApiHost": "https://api.kalevamedia.fi", "appSlug": "kalevafi", "threadSlug": "article-5138103", "xApiKey": "HSyHVnWuN96Lvm65vjoln7cFICoF4hDj65SEgsiz", "loginUrl": "/leeloo/kirjaudu/?brand=kalevafi", "signupUrl": "/leeloo/kirjaudu/?luotunnus=1&brand=kalevafi"}
             
           )
         ),
         el
        );
    });
  };
  var require = function (scripts, callbackFn) {
    scripts.forEach(function(script) {
      if (!loadjs.isDefined(script)) {
        loadjs(script, script);
      }
    });
    loadjs.ready(scripts, callbackFn);
  };
  require(scripts, loadComponent);
 })();
</script>

    
  </div>

      
    </div>
  </section>

  <section class="mdc-layout-grid__inner">
    <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-7">
      <div class="content-widget--frontpage-now -ctx-article">
        
        
        
<div class="__widget_TabbedContentWidget" data-uninitialized="true"></div>

<script>
  (function() {
  var initKey = 'data-uninitialized';
  var el = document.querySelector('.__widget_TabbedContentWidget[' + initKey + '=true]');
  el.removeAttribute(initKey);
  var scripts = ["/staticfiles/webpack_bundles/app-2639a17664fccd6d8e87.js"];
  var loadComponent = function() {
    Loadable.preloadReady().then(function() {
      ReactDOM.render(
        React.createElement(
          Provider,
          { store: createLocalStore() },
           React.createElement(Components.TabbedContentWidget,
             
               {"title": "Etusivulla nyt", "styleContext": "-ctx-frontpage-now -level-1", "imageFormat": "ratio_3x2", "imageSize": 410, "tabs": [{"title": "Uusimmat", "query": "/api/v2/channels/kalevafi/managed-listings/etusivu/?limit=30&omit=content.gallery.items"}], "ugcRibbonVersion": "small"}
             
           )
         ),
         el
        );
    });
  };
  var require = function (scripts, callbackFn) {
    scripts.forEach(function(script) {
      if (!loadjs.isDefined(script)) {
        loadjs(script, script);
      }
    });
    loadjs.ready(scripts, callbackFn);
  };
  require(scripts, loadComponent);
 })();
</script>

      </div>
    </div>
    <aside class="mdc-layout-grid__cell mdc-layout-grid__cell--span-5 sidebar__column-container">
      
        
        <div class="sidebar__column-item -ad -ad3">
          <div class="sidebar-sticky-container">
            <div class="ad-container ad-container--sidebar">
              
  
  <div id="sidebar3" data-placement-id="sidebar3" class="lyta-lazy-load"></div>
  <script>
  try {
    Lyta.render({
      adUnit: "sidebar3",
      async: true,
      adContainer: "sidebar3",
      
      checkVisibility: true
    });
  }
  catch(error) {
    try {
      Lyta.log(error);
    }
    catch(logerror) {
      console.log(error);
    }
  }
  </script>
  

            </div>
          </div>
        </div>
      
    </aside>
  </section>

  
  
    
    
<div class="__widget_MobileMenuSnackbar" data-uninitialized="true"></div>

<script>
  (function() {
  var initKey = 'data-uninitialized';
  var el = document.querySelector('.__widget_MobileMenuSnackbar[' + initKey + '=true]');
  el.removeAttribute(initKey);
  var scripts = ["/staticfiles/webpack_bundles/app-2639a17664fccd6d8e87.js"];
  var loadComponent = function() {
    Loadable.preloadReady().then(function() {
      ReactDOM.render(
        React.createElement(
          Provider,
          { store: createLocalStore() },
           React.createElement(Components.MobileMenuSnackbar,
             
               {"frontpageUrl": "https://www.kaleva.fi", "logoUrl": "/staticfiles/londo/domains/kalevafi/site/images/kalevafi--white-logo-2x.734e62591d46.png"}
             
           )
         ),
         el
        );
    });
  };
  var require = function (scripts, callbackFn) {
    scripts.forEach(function(script) {
      if (!loadjs.isDefined(script)) {
        loadjs(script, script);
      }
    });
    loadjs.ready(scripts, callbackFn);
  };
  require(scripts, loadComponent);
 })();
</script>

  

  
  
    
    
<div class="__widget_RecommendationSnackbar" data-uninitialized="true"></div>

<script>
  (function() {
  var initKey = 'data-uninitialized';
  var el = document.querySelector('.__widget_RecommendationSnackbar[' + initKey + '=true]');
  el.removeAttribute(initKey);
  var scripts = ["/staticfiles/webpack_bundles/app-2639a17664fccd6d8e87.js"];
  var loadComponent = function() {
    Loadable.preloadReady().then(function() {
      ReactDOM.render(
        React.createElement(
          Provider,
          { store: createLocalStore() },
           React.createElement(Components.RecommendationSnackbar,
             
               {"channel": "kalevafi", "articleID": 5138103, "listSlug": "sinulle-ponnahtavat-suositukset", "listTitle": "Sinulle ponnahtavat suositukset", "uiEnabled": true, "mainKeyword": "liikennemerkit"}
             
           )
         ),
         el
        );
    });
  };
  var require = function (scripts, callbackFn) {
    scripts.forEach(function(script) {
      if (!loadjs.isDefined(script)) {
        loadjs(script, script);
      }
    });
    loadjs.ready(scripts, callbackFn);
  };
  require(scripts, loadComponent);
 })();
</script>

  

         </main>
      </div>
    
    

    <footer class="footer">
  <div class="mdc-layout-grid">
    <div class="mdc-layout-grid__inner">
      <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-3-desktop mdc-layout-grid__cell--span-4-tablet">
        <section class="footer__content">
          




  



  <div class="footer-main__wrapper">
    <ul class="footer-main-menu footer-main-menu--level-1 js-footer-main-menu">
      
  <li class="footer-main-menu__item footer-main-menu__item--level-1 footer-main-menu__item--tilaa-kaleva-2 -highlight">
    

      
        
      

      <div class="footer-main-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/tilaa-kaleva-3/?utm_source=kaleva&amp;utm_medium=sfooter&amp;utm_campaign=tam22" class="footer-main-menu__item-link footer-main-menu__item-link--level-1 footer-main-menu__item-link--tilaa-kaleva-2" target="_blank" rel="noopener">
          Tilaa Kaleva
        </a>
      

      </div>

    

    
      <ul class="footer-main-menu footer-main-menu--level-2">
        
  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--laheta-vinkki-kuva-tai-video -highlight">
    

      
        
      

      <div class="footer-main-menu__item--highlight-wrapper">

      
        
          
        
        <a href="/lukijalta/laheta" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--laheta-vinkki-kuva-tai-video" >
          Lähetä vinkki, kuva tai video
        </a>
      

      </div>

    

    
  </li>

      </ul>
    
  </li>

  <li class="footer-main-menu__item footer-main-menu__item--level-1 footer-main-menu__item--asiakaspalvelu-5 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/" class="footer-main-menu__item-link footer-main-menu__item-link--level-1 footer-main-menu__item-link--asiakaspalvelu-5" target="_blank" rel="noopener">
          Asiakaspalvelu
        </a>
      

      

    

    
      <ul class="footer-main-menu footer-main-menu--level-2">
        
  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--jata-lukijailmoitus-3 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/lukijailmoitukset/" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--jata-lukijailmoitus-3" target="_blank" rel="noopener">
          Jätä lukijailmoitus
        </a>
      

      

    

    
  </li>

  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--palvelumme-yrityksille-7 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.kalevamedia.fi/yrityksille" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--palvelumme-yrityksille-7" target="_blank" rel="noopener">
          Palvelumme yrityksille
        </a>
      

      

    

    
  </li>

  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--kaleva-media-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.kalevamedia.fi/" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--kaleva-media-2" target="_blank" rel="noopener">
          Kaleva Media
        </a>
      

      

    

    
  </li>

  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--tietosuoja-2 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://www.kalevamedia.fi/tietoa-meista/tietosuoja/" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--tietosuoja-2" target="_blank" rel="noopener">
          Tietosuoja
        </a>
      

      

    

    
  </li>

  <li class="footer-main-menu__item footer-main-menu__item--level-2 footer-main-menu__item--kayttoehdot-4 -normal">
    

      
        
      

      

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kayttoehdot/" class="footer-main-menu__item-link footer-main-menu__item-link--level-2 footer-main-menu__item-link--kayttoehdot-4" target="_blank" rel="noopener">
          Käyttöehdot
        </a>
      

      

    

    
  </li>

      </ul>
    
  </li>

    </ul>
  </div>

        </section>
      </div>
      <div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-9-desktop mdc-layout-grid__cell--span-8-tablet">
        <section class="footer__content">
          <header class="footer__content__header">
            Ota yhteyttä
          </header>
          




  



  <div class="footer-contacts__wrapper">
    <ul class="footer-contacts-menu footer-contacts-menu--level-1 js-footer-contacts-menu">
      
  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-1 footer-contacts-menu__item--toimitus-2 -highlight">
    

      
        
      

      <div class="footer-contacts-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/yhteystiedot/#toimitus" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-1 footer-contacts-menu__item-link--toimitus-2" target="_blank" rel="noopener">
          Toimitus
        </a>
      

      </div>

    

    
      <ul class="footer-contacts-menu footer-contacts-menu--level-2">
        
  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--toimituskalevafi -normal">
    

      
        
      

      

      
        
          
        
        <a href="mailto:toimitus@kaleva.fi" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--toimituskalevafi" >
          toimitus@kaleva.fi
        </a>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--08-5377-111 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--08-5377-111">
          (08) 5377 111
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item---9 -separator">
    
      <div class="footer-contacts-menu__item-separator footer-contacts-menu__item-separator--level-2"></div>
    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--paatoimittaja-sanna-keskinen -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--paatoimittaja-sanna-keskinen">
          Päätoimittaja Sanna Keskinen
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--postiosoite -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--postiosoite">
          Postiosoite: 
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--kalevatoimitus-pl-170-90401-oulu -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--kalevatoimitus-pl-170-90401-oulu">
          Kaleva/toimitus PL 170, 90401 OULU
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--kayntiosoite -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--kayntiosoite">
          Käyntiosoite: 
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--solistinkatu-4-90140-oulu -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--solistinkatu-4-90140-oulu">
          Solistinkatu 4, 90140 OULU
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--julkaisija-kaleva365-oy-8 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--julkaisija-kaleva365-oy-8">
          Julkaisija: Kaleva365 Oy
        </span>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-1 footer-contacts-menu__item--asiakaspalvelu-6 -highlight">
    

      
        
      

      <div class="footer-contacts-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://asiakaspalvelu.kaleva.fi/kaleva/" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-1 footer-contacts-menu__item-link--asiakaspalvelu-6" target="_blank" rel="noopener">
          Asiakaspalvelu
        </a>
      

      </div>

    

    
      <ul class="footer-contacts-menu footer-contacts-menu--level-2">
        
  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--08-5377-610 -normal">
    

      
        
      

      

      
        
          
        
        <a href="tel:085377610" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--08-5377-610" >
          (08) 5377 610
        </a>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--mape-921-lasu-917 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--mape-921-lasu-917">
          ma–pe 9–21, la–su 9–17
        </span>
      

      

    

    
  </li>

      </ul>
    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-1 footer-contacts-menu__item--palvelumme-yrityksille-6 -highlight">
    

      
        
      

      <div class="footer-contacts-menu__item--highlight-wrapper">

      
        
          
        
        <a href="https://www.kalevamedia.fi/yrityksille" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-1 footer-contacts-menu__item-link--palvelumme-yrityksille-6" target="_blank" rel="noopener">
          Palvelumme yrityksille
        </a>
      

      </div>

    

    
      <ul class="footer-contacts-menu footer-contacts-menu--level-2">
        
  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--yrityksillekalevamediafi-8 -normal">
    

      
        
      

      

      
        
          
        
        <a href="mailto:yrityksille@kalevamedia.fi" class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--yrityksillekalevamediafi-8" >
          yrityksille@kalevamedia.fi
        </a>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item---17 -separator">
    
      <div class="footer-contacts-menu__item-separator footer-contacts-menu__item-separator--level-2"></div>
    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--kaleva-media-5 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--kaleva-media-5">
          Kaleva Media
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--pl-170-90401-oulu -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--pl-170-90401-oulu">
          PL 170, 90401 Oulu
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--08-5377-180-4 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--08-5377-180-4">
          08 5377 180
        </span>
      

      

    

    
  </li>

  <li class="footer-contacts-menu__item footer-contacts-menu__item--level-2 footer-contacts-menu__item--mape-klo-816 -normal">
    

      
        
      

      

      
        <span class="footer-contacts-menu__item-link footer-contacts-menu__item-link--level-2 footer-contacts-menu__item-link--mape-klo-816">
          (ma–pe klo 8–16)
        </span>
      

      

    

    
  </li>

      </ul>
    
  </li>

    </ul>
  </div>

        </section>
      </div>
    </div>
  </div>
</footer>

<footer class="subfooter">
  <div class="mdc-layout-grid">
    <a href="/" class="subfooter__logo">
      <img src="/staticfiles/londo/domains/kalevafi/site/images/kalevafi--logo-2x.31853ca9aef6.png" alt="Kaleva" />
    </a>
    
    
  
  
  
  
<div class="subfooter__icons">
  
  <a href="https://www.facebook.com/KalevaOy" class="subfooter__icon-link">
    <i class="subfooter__icon -facebook"></i>
  </a>
  

  
  <a href="https://twitter.com/Kaleva_fi" class="subfooter__icon-link">
    <i class="subfooter__icon -twitter"></i>
  </a>
  

  
  <a href="https://www.instagram.com/kaleva_fi/" class="subfooter__icon-link">
    <i class="subfooter__icon -instagram"></i>
  </a>
  
</div>



    <div class="subfooter__ext-logos">
      
        <div class="subfooter__ext-logo">
          <img src="/staticfiles/londo/images/vastuullistajournalismia_150.44250113d663.png">
        </div>
      
    </div>
  </div>
</footer>

    <script>
      var FB_APP_ID = '499246010097508';
    </script>

    <script src="/staticfiles/webpack_bundles/common-2639a17664fccd6d8e87.js" ></script>
    <script src="/staticfiles/webpack_bundles/consent-2639a17664fccd6d8e87.js" ></script>
    <script type="text/javascript" src="https://cdn.jsdelivr.net/npm/lozad/dist/lozad.min.js"></script>
    <script>
      var observer = lozad('.lozad', {
        threshold: 0.1,
        rootMargin: '512px 0px 512px 0px',
        loaded: function(el) {
          el.onload = function() {
            el.dataset['complete'] = true;
          }
        }
      });
      observer.observe();
    </script>
    

    <script src="/staticfiles/londo/site/js/ie-notice.92fbe6ee0d8c.js"></script>
  <script type="text/javascript">
  if (!window.Zephr) window.Zephr = {};
  window.Zephr.accessDetails = {"isAuthenticated":false,"accessDecisions":{},"entitlements":{},"credits":{},"meters":{},"trials":{"hccBMu":{"isUsedInDecision":true,"isDecrementedInDecision":true,"totalCredits":6,"remainingCredits":5,"tracker":"paywall-kalevafi-default-anonymous","reportInDataLayer":false,"dataLayerCreditsUsedKey":"trial-hccBMu-creditsUsed","dataLayerCreditsRemainingKey":"trial-hccBMu-creditsRemaining"},"hLbCQK":{"isUsedInDecision":false}},"trialTrackingDetails":[],"testGroups":{"57e06aa5-b05f-48d6-8449-dcce669d1afe":"B","5df66a42-2684-4021-ad14-1349633d72e7":"A","88ffa924-fb0c-4625-8821-37c90d1cc472":"A","cd14a9e2-47ae-4579-adc9-9b3d99e2b2f0":"A","d73bb199-519e-493d-bd35-a7871e153356":"B"},"activeProducts":[]};
</script>
<script type="text/javascript">
  window.Zephr = window.Zephr || {};
  window.Zephr.includeOutcomes = true;
  window.Zephr.outcomesAsEvents = true;
  window.Zephr.groupFields = true;
</script><script async type="text/javascript">
(function() {
    var xhr = new(XMLHttpRequest || ActiveXObject)('MSXML2.XMLHTTP.3.0');
    xhr.open('GET', '/blaize/datalayer', true);
    xhr.onreadystatechange = function() {
        if (xhr.readyState === 4) {
            var response;
            try {
                response = JSON.parse(xhr.response);
            } catch (e) {
                response = xhr.response;
            }
            if (xhr.status === 200) {
                for (var dataLayerFieldName in response) {
                    if (!(dataLayerFieldName in window)) window[dataLayerFieldName] = [];

                    var pageView = response[dataLayerFieldName];
                    var events = [];

                    if (window.Zephr && window.Zephr.includeOutcomes && window.Zephr.outcomes) {
                        pageView.zephrOutcomes = window.Zephr.outcomes;

                        if (window.Zephr.outcomesAsEvents) {
                            Object.keys(window.Zephr.outcomes || []).forEach(function(outcomeKey) {
                                var outcomeEvent = {
                                    event: "zephr-outcome-" + outcomeKey,
                                    featureId: outcomeKey,
                                    featureLabel: window.Zephr.outcomes[outcomeKey].featureLabel,
                                    outcomeId: window.Zephr.outcomes[outcomeKey].outcomeId,
                                    outcomeLabel: window.Zephr.outcomes[outcomeKey].outcomeLabel,
                                };
                                events.push(outcomeEvent);
                            });
                        }
                    }
                    if (window.Zephr && window.Zephr.accessDetails) {
                        Object.keys((window.Zephr.accessDetails.trials || {})).forEach(function(trialId){
                            var trial = window.Zephr.accessDetails.trials[trialId]
                            if(trial.reportInDataLayer){
                                var usedCredits = trial.totalCredits - trial.remainingCredits
                                if (window.Zephr.groupFields && !pageView.zephrTrials) pageView.zephrTrials = {};
                                var target = window.Zephr.groupFields ? pageView.zephrTrials : pageView
                                if (trial.dataLayerCreditsUsedKey) {
                                   target[trial.dataLayerCreditsUsedKey] = usedCredits;
                                }
                                if (trial.dataLayerCreditsRemainingKey) {
                                   target[trial.dataLayerCreditsRemainingKey] = trial.remainingCredits;
                                }
                            }
                        });
                        (window.Zephr.accessDetails.trialTrackingDetails || []).forEach(function(details) {
                            var type = details.entitlementType === 'credits' ? 'credits' : 'meters';
                            var trial = (window.Zephr.accessDetails[type] || {})[details.entitlementId];
                            if (!trial) return;
                            if (window.Zephr.groupFields && !pageView.zephrTrials) pageView.zephrTrials = {};
                            if (details.creditsRemainingKey) {
                                if (window.Zephr.groupFields) {
                                    pageView.zephrTrials[details.creditsRemainingKey] = trial.remainingCredits;
                                } else {
                                    pageView[details.creditsRemainingKey] = trial.remainingCredits;
                                }
                            }
                            if (details.creditsUsedKey) {
                                if (window.Zephr.groupFields) {
                                    pageView.zephrTrials[details.creditsUsedKey] = trial.totalCredits - trial.remainingCredits;
                                } else {
                                    pageView[details.creditsUsedKey] = trial.totalCredits - trial.remainingCredits;
                                }
                            }
                        });
                    }
                    if (Object.keys(pageView).length) {
                        pageView.event = "zephr-pageview";
                        events.unshift(pageView);
                    }
                    if (!events.length) continue;

                    events.forEach(function(event) {
                        window[dataLayerFieldName].push(event);
                    });
                }
                var readyEvent = document.createEvent('Event');
                readyEvent.initEvent('zephr.dataLayerReady', true, true);
                document.dispatchEvent(readyEvent);
            }
        }
    }
    xhr.send({});
})();

</script></body>
</html>